summaryrefslogtreecommitdiff
path: root/packages/e17/entrance_0.9.0.007.bb
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2006-05-12 19:33:42 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-12 19:33:42 +0000
commit5801f1d73d5dd9ab259000c9a606d304916c5a46 (patch)
tree269ee0e363abb426782c961170d330cc1642d609 /packages/e17/entrance_0.9.0.007.bb
parent3afa784bb8cba63d6ba8507d1d083224a51fa787 (diff)
efl, e17: update to newest versions
Diffstat (limited to 'packages/e17/entrance_0.9.0.007.bb')
-rw-r--r--packages/e17/entrance_0.9.0.007.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/packages/e17/entrance_0.9.0.007.bb b/packages/e17/entrance_0.9.0.007.bb
new file mode 100644
index 0000000000..4237427d63
--- /dev/null
+++ b/packages/e17/entrance_0.9.0.007.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Entrance is the Enlightenment login manager"
+LICENSE = "MIT"
+# can also use pam and crypt
+DEPENDS = "edb edb-native evas-x11 ecore-x11 edje esmart-x11 bash keylaunch detect-stylus xserver-common login-manager"
+RDEPENDS += "bash keylaunch detect-stylus xserver-common glibc-gconv-iso8859-1 login-manager entrance-themes"
+HOMEPAGE = "http://www.enlightenment.org"
+PR = "r13"
+
+inherit e
+
+SRC_URI = "${E_URI}/entrance-${PV}.tar.gz \
+ file://config-db.patch;patch=1 \
+ file://allow-missing-xsession.patch;patch=1 \
+ file://run-Xinit.patch;patch=1 \
+ file://set-display-env.patch;patch=1 \
+ file://fix-auth-mode.patch;patch=1 \
+ file://use-bash.patch;patch=1 \
+ file://disable-autodetect.patch;patch=1 \
+ file://Sessions"
+
+S = "${WORKDIR}/entrance-${PV}"
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc \
+ --with-xsession=/etc/X11/Xsession \
+ --with-auth-mode=0"
+
+FILES_${PN} += "${bindir} ${sbindir} /etc ${datadir}"
+
+do_install_append() {
+ install -d ${D}/etc/X11/Xsession.d
+ install -d ${D}/etc/X11/Sessions
+
+ install -m 755 ${WORKDIR}/Sessions/* ${D}/etc/X11/Sessions
+
+ install -d ${D}/etc/X11/login-managers/
+ mv ${D}/etc/init.d/entrance ${D}/etc/X11/login-managers/entrance
+}