summaryrefslogtreecommitdiff
path: root/packages/e17/entrance_0.9.0.005.bb
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2006-02-06 00:46:35 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-06 00:46:35 +0000
commit9b188ea2600bce6ed35559b21677bd8b7223f5a8 (patch)
tree40e9328ce853279c0eae8ecc851d514ef01c26d1 /packages/e17/entrance_0.9.0.005.bb
parent76107d774ec7a96b7788d2f2b98b5621a04cfe71 (diff)
parent1be31761f3449cd4f92508fd2c2c41968039c918 (diff)
merge of 1133a2f6d7624f04cdda9771f28e1502680e7213
and 59438d13db19ded8e22646fb8cddf849804f3a90
Diffstat (limited to 'packages/e17/entrance_0.9.0.005.bb')
-rw-r--r--packages/e17/entrance_0.9.0.005.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/e17/entrance_0.9.0.005.bb b/packages/e17/entrance_0.9.0.005.bb
new file mode 100644
index 0000000000..b79e26d4a4
--- /dev/null
+++ b/packages/e17/entrance_0.9.0.005.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "Entrance is the Enlightenment login manager"
+SECTION = "e/apps"
+LICENSE = "MIT"
+# can also use pam and crypt
+DEPENDS = "edb edb-native evas-x11 ecore-x11 edje esmart-x11 bash keylaunch detect-stylus xserver-common"
+RDEPENDS += "bash keylaunch detect-stylus xserver-common glibc-gconv-iso8859-1"
+HOMEPAGE = "http://www.enlightenment.org"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+PR = "r11"
+
+SRC_URI = "http://enlightenment.freedesktop.org/files/entrance-${PV}.tar.gz \
+ file://config-db.patch;patch=1 \
+ file://allow-missing-xsession.patch;patch=1 \
+ file://run-Xinit.patch;patch=1 \
+ file://set-display-env.patch;patch=1 \
+ file://fix-auth-mode.patch;patch=1 \
+ file://use-bash.patch;patch=1 \
+ file://Sessions"
+
+S = "${WORKDIR}/entrance-${PV}"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "entrance"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc \
+ --with-xsession=/etc/X11/Xsession \
+ --with-auth-mode=0"
+
+FILES += "${datadir}"
+
+do_install_append() {
+ install -d ${D}/etc/X11/Xsession.d
+ install -d ${D}/etc/X11/Sessions
+
+ install -m 755 ${WORKDIR}/Sessions/* ${D}/etc/X11/Sessions
+}