summaryrefslogtreecommitdiff
path: root/packages/e17/entrance_0.9.0.005.bb
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2006-02-04 01:49:45 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-04 01:49:45 +0000
commit77200613aa4a12968f0b793ab5553342b250ce41 (patch)
treec5b02d2e9d6784ac5eda5509b94d84478b772114 /packages/e17/entrance_0.9.0.005.bb
parent0c8f25a194d556d79f64e7df0a47a6254507e36b (diff)
efl, e17: Update to newer release tarballs
- Removed no-splash patch for e-wm, crash bug seems to be gone - add "released" entrance - remove ecore fixes (fixed in release...finally) - add new configure fix for evas and change configure patch names to use ${PV}
Diffstat (limited to 'packages/e17/entrance_0.9.0.005.bb')
-rw-r--r--packages/e17/entrance_0.9.0.005.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/e17/entrance_0.9.0.005.bb b/packages/e17/entrance_0.9.0.005.bb
new file mode 100644
index 0000000000..b79e26d4a4
--- /dev/null
+++ b/packages/e17/entrance_0.9.0.005.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "Entrance is the Enlightenment login manager"
+SECTION = "e/apps"
+LICENSE = "MIT"
+# can also use pam and crypt
+DEPENDS = "edb edb-native evas-x11 ecore-x11 edje esmart-x11 bash keylaunch detect-stylus xserver-common"
+RDEPENDS += "bash keylaunch detect-stylus xserver-common glibc-gconv-iso8859-1"
+HOMEPAGE = "http://www.enlightenment.org"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+PR = "r11"
+
+SRC_URI = "http://enlightenment.freedesktop.org/files/entrance-${PV}.tar.gz \
+ file://config-db.patch;patch=1 \
+ file://allow-missing-xsession.patch;patch=1 \
+ file://run-Xinit.patch;patch=1 \
+ file://set-display-env.patch;patch=1 \
+ file://fix-auth-mode.patch;patch=1 \
+ file://use-bash.patch;patch=1 \
+ file://Sessions"
+
+S = "${WORKDIR}/entrance-${PV}"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "entrance"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc \
+ --with-xsession=/etc/X11/Xsession \
+ --with-auth-mode=0"
+
+FILES += "${datadir}"
+
+do_install_append() {
+ install -d ${D}/etc/X11/Xsession.d
+ install -d ${D}/etc/X11/Sessions
+
+ install -m 755 ${WORKDIR}/Sessions/* ${D}/etc/X11/Sessions
+}