summaryrefslogtreecommitdiff
path: root/packages/e17/entrance_0.9.0.005.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-02-06 01:31:29 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-06 01:31:29 +0000
commit69d51a4e09adf355137b0cac65eda31227723c3e (patch)
treed2b3b44f0ab187354f7fb15935cb85721014b6e1 /packages/e17/entrance_0.9.0.005.bb
parentdc7f3136445c3fdf6003b4b00615fbc72d950ca3 (diff)
parent062e000a4691d4884a3ae0233246fb259a335969 (diff)
merge of 2510e5252ac32a4848eb302514a1d35602ed7afd
and 65b0cd64eeef02b789460148d6bb958749417f11
Diffstat (limited to 'packages/e17/entrance_0.9.0.005.bb')
-rw-r--r--packages/e17/entrance_0.9.0.005.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/e17/entrance_0.9.0.005.bb b/packages/e17/entrance_0.9.0.005.bb
new file mode 100644
index 0000000000..b79e26d4a4
--- /dev/null
+++ b/packages/e17/entrance_0.9.0.005.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "Entrance is the Enlightenment login manager"
+SECTION = "e/apps"
+LICENSE = "MIT"
+# can also use pam and crypt
+DEPENDS = "edb edb-native evas-x11 ecore-x11 edje esmart-x11 bash keylaunch detect-stylus xserver-common"
+RDEPENDS += "bash keylaunch detect-stylus xserver-common glibc-gconv-iso8859-1"
+HOMEPAGE = "http://www.enlightenment.org"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+PR = "r11"
+
+SRC_URI = "http://enlightenment.freedesktop.org/files/entrance-${PV}.tar.gz \
+ file://config-db.patch;patch=1 \
+ file://allow-missing-xsession.patch;patch=1 \
+ file://run-Xinit.patch;patch=1 \
+ file://set-display-env.patch;patch=1 \
+ file://fix-auth-mode.patch;patch=1 \
+ file://use-bash.patch;patch=1 \
+ file://Sessions"
+
+S = "${WORKDIR}/entrance-${PV}"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "entrance"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc \
+ --with-xsession=/etc/X11/Xsession \
+ --with-auth-mode=0"
+
+FILES += "${datadir}"
+
+do_install_append() {
+ install -d ${D}/etc/X11/Xsession.d
+ install -d ${D}/etc/X11/Sessions
+
+ install -m 755 ${WORKDIR}/Sessions/* ${D}/etc/X11/Sessions
+}