summaryrefslogtreecommitdiff
path: root/packages/e17/e-wm_0.16.999.032.bb
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2006-08-04 01:36:54 +0000
committerJustin Patrin <papercrane@gmail.com>2006-08-04 01:36:54 +0000
commit266090bb5ffc806d4ca83f18d56f89d949cce7df (patch)
tree1d586f825ea1cff57e4631c8485ff41cbf7ff63c /packages/e17/e-wm_0.16.999.032.bb
parentaea055157aed744658bfebd73cbe4490d0fe2650 (diff)
efl, e17: update to newest versions, remove e as the src/lib dir seems to be gone
Diffstat (limited to 'packages/e17/e-wm_0.16.999.032.bb')
-rw-r--r--packages/e17/e-wm_0.16.999.032.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/packages/e17/e-wm_0.16.999.032.bb b/packages/e17/e-wm_0.16.999.032.bb
new file mode 100644
index 0000000000..fd8814a8ee
--- /dev/null
+++ b/packages/e17/e-wm_0.16.999.032.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "E17 - the Enlightenment Window Mananger"
+DEPENDS = "evas-x11 ecore-x11 edje eet embryo"
+LICENSE = "MIT"
+PR = "r3"
+
+inherit e update-alternatives
+
+SRC_URI = "${E_URI}/enlightenment-${PV}.tar.gz \
+ file://fix-configure.patch;patch=1 \
+ file://Xsession.d/98enlightenment"
+
+S = "${WORKDIR}/enlightenment-${PV}"
+
+PROFILE = "LOWRES_PDA"
+PROFILE_c7x0 = "HIRES_PDA"
+PROFILE_tosa = "HIRES_PDA"
+PROFILE_spitz = "HIRES_PDA"
+PROFILE_akita = "HIRES_PDA"
+
+EXTRA_OECONF = "--with-profile=${PROFILE} \
+ --with-edje-cc=${STAGING_BINDIR}/edje_cc \
+ --x-includes=${STAGING_INCDIR}/X11 \
+ --x-libraries=${STAGING_LIBDIR}"
+
+FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} ${sysconfdir}"
+
+do_compile_prepend() {
+ find ${S} -name Makefile | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
+ find ${S} -name Makefile | xargs sed -i 's:/usr/X11R6/include:${STAGING_INCDIR}:'
+}
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/X11/Xsession.d
+ install -m 755 ${WORKDIR}/Xsession.d/98enlightenment ${D}/${sysconfdir}/X11/Xsession.d
+}
+
+ALTERNATIVE_PATH = "${bindir}/enlightenment"
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PRIORITY = "16"