summaryrefslogtreecommitdiff
path: root/packages/dtnrg
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-02-29 15:59:47 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-02-29 15:59:47 +0000
commitd8618d0ce0ee1bf7ad72efac9cbf5626a2897698 (patch)
treefc29126a2695526378cef852bc57bf7b6d219df5 /packages/dtnrg
parent5a362b4bb805986fbb4a5e0aee08d23b62d84b05 (diff)
parent5e33f4db5f153d6b3e3cc9c75523e9ce9288e396 (diff)
merge of '7ebcf65940382b7ebea258189704cb0e4a77dc70'
and 'ae9980c1d055e682beb2fea6cfddb080c495b43b'
Diffstat (limited to 'packages/dtnrg')
-rw-r--r--packages/dtnrg/dtn_2.5.0.bb19
1 files changed, 10 insertions, 9 deletions
diff --git a/packages/dtnrg/dtn_2.5.0.bb b/packages/dtnrg/dtn_2.5.0.bb
index 5975a29e7c..3878829ce5 100644
--- a/packages/dtnrg/dtn_2.5.0.bb
+++ b/packages/dtnrg/dtn_2.5.0.bb
@@ -3,29 +3,30 @@ HOMEPAGE = "http://www.dtnrg.org/wiki"
SECTION = "libs"
DEPENDS = "db openssl python-native xerces-c"
LICENSE = "Apache"
-SRC_URI = "http://www.dtnrg.org/docs/code/dtn_${PV}.tgz"
-PR = "r2"
+SRC_URI = "http://www.dtnrg.org/docs/code/dtn_${PV}.tgz \
+ file://configure_fix.patch;patch=1"
+PR = "r3"
inherit autotools
EXTRA_OECONF = "\
--with-python=${STAGING_BINDIR_NATIVE}/python \
- --with-db=${STAGING_DIR} \
- --with-tcl=${STAGING_DIR} \
+ --with-db=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --with-tcl=${STAGING_DIR_HOST}${layout_exec_prefix} \
--without-google-perftools \
--without-bluez \
--without-bonjour \
- --with-expat=${STAGING_DIR} \
- --with-xerces-c=${STAGING_DIR} \
+ --with-expat=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --with-xerces-c=${STAGING_DIR_HOST}${layout_exec_prefix} \
--without-tclreadline \
- --with-zlib=${STAGING_DIR} \
+ --with-zlib=${STAGING_DIR_HOST}${layout_exec_prefix} \
--without-xsd-tool \
- --with-db=${STAGING_DIR} \
+ --with-db=${STAGING_DIR_HOST}${layout_exec_prefix} \
--enable-ecl \
--enable-edp \
--without-mysql \
--without-postgres \
- --with-openssl=${STAGING_DIR} \
+ --with-openssl=${STAGING_DIR_HOST}${layout_exec_prefix} \
"
def dtn_python_dir(d):