summaryrefslogtreecommitdiff
path: root/packages/dtnrg/dtn_2.5.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2008-02-28 12:41:00 +0000
committerRichard Purdie <rpurdie@rpsys.net>2008-02-28 12:41:00 +0000
commitf66378d955987691415e8f4786f87f92f5303241 (patch)
tree19ff2613e347a3f73f2e029040256abcac1ffe8c /packages/dtnrg/dtn_2.5.0.bb
parent54459388bca56e8cccefe0799082a958e5b8a709 (diff)
parent4713d888ebcf7e0a9064346bf3f0a86d22ad7129 (diff)
merge of '0392f48f534dce561d4b8cb01e8db5ad64500222'
and 'a141267452dde7cd1e229a81095e09d64b4c3e9d'
Diffstat (limited to 'packages/dtnrg/dtn_2.5.0.bb')
-rw-r--r--packages/dtnrg/dtn_2.5.0.bb19
1 files changed, 10 insertions, 9 deletions
diff --git a/packages/dtnrg/dtn_2.5.0.bb b/packages/dtnrg/dtn_2.5.0.bb
index 5975a29e7c..3878829ce5 100644
--- a/packages/dtnrg/dtn_2.5.0.bb
+++ b/packages/dtnrg/dtn_2.5.0.bb
@@ -3,29 +3,30 @@ HOMEPAGE = "http://www.dtnrg.org/wiki"
SECTION = "libs"
DEPENDS = "db openssl python-native xerces-c"
LICENSE = "Apache"
-SRC_URI = "http://www.dtnrg.org/docs/code/dtn_${PV}.tgz"
-PR = "r2"
+SRC_URI = "http://www.dtnrg.org/docs/code/dtn_${PV}.tgz \
+ file://configure_fix.patch;patch=1"
+PR = "r3"
inherit autotools
EXTRA_OECONF = "\
--with-python=${STAGING_BINDIR_NATIVE}/python \
- --with-db=${STAGING_DIR} \
- --with-tcl=${STAGING_DIR} \
+ --with-db=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --with-tcl=${STAGING_DIR_HOST}${layout_exec_prefix} \
--without-google-perftools \
--without-bluez \
--without-bonjour \
- --with-expat=${STAGING_DIR} \
- --with-xerces-c=${STAGING_DIR} \
+ --with-expat=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --with-xerces-c=${STAGING_DIR_HOST}${layout_exec_prefix} \
--without-tclreadline \
- --with-zlib=${STAGING_DIR} \
+ --with-zlib=${STAGING_DIR_HOST}${layout_exec_prefix} \
--without-xsd-tool \
- --with-db=${STAGING_DIR} \
+ --with-db=${STAGING_DIR_HOST}${layout_exec_prefix} \
--enable-ecl \
--enable-edp \
--without-mysql \
--without-postgres \
- --with-openssl=${STAGING_DIR} \
+ --with-openssl=${STAGING_DIR_HOST}${layout_exec_prefix} \
"
def dtn_python_dir(d):