summaryrefslogtreecommitdiff
path: root/packages/dsplink/files
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-07-16 08:33:56 +0000
committerKoen Kooi <koen@openembedded.org>2008-07-16 08:33:56 +0000
commit4ff8f98603885e1647668f4c218969b65d778f54 (patch)
treef987fb98b992cd3a8920dd7c4c3b2c8c74c99232 /packages/dsplink/files
parent4fe64e497bb8af2ca8298c7b5af3f52d68e0467d (diff)
dsplink: add glue to hook in TI dspbios and TI c64x compiler trees into the build
* The user needs to obtain dspbios and cgtools on its own and override the TI*DIR vars in local.conf to point to the correct location, default is /OE/TI
Diffstat (limited to 'packages/dsplink/files')
-rw-r--r--packages/dsplink/files/c64xx_5.xx_linux.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/packages/dsplink/files/c64xx_5.xx_linux.mk b/packages/dsplink/files/c64xx_5.xx_linux.mk
index d0b27d7a55..8e0e8cd116 100644
--- a/packages/dsplink/files/c64xx_5.xx_linux.mk
+++ b/packages/dsplink/files/c64xx_5.xx_linux.mk
@@ -35,8 +35,8 @@ USE_DISTRIBUTION := 1
# ----------------------------------------------------------------------------
# Base directory for the DSP OS
# ----------------------------------------------------------------------------
-BASE_INSTALL := /opt/ti-tools
-BASE_SABIOS := $(BASE_INSTALL)/bios
+BASE_INSTALL := SEDME_TITOOLS_BASEPATH
+BASE_SABIOS := $(BASE_INSTALL)/SEDME_BIOSUNPACKDIR
BASE_BUILDOS := $(BASE_SABIOS)/packages/ti/bios
# ----------------------------------------------------------------------------
@@ -47,7 +47,7 @@ XDCTOOLS_DIR := $(BASE_SABIOS)/xdctools
# ----------------------------------------------------------------------------
# Base for code generation tools - compiler, linker, archiver etc.
# ----------------------------------------------------------------------------
-BASE_CGTOOLS := $(BASE_INSTALL)/c6000/cgtools
+BASE_CGTOOLS := $(BASE_INSTALL)/SEDME_CGTOOLSDIR
BASE_CGTOOLSBIN := $(BASE_CGTOOLS)/bin
# ----------------------------------------------------------------------------
@@ -135,7 +135,7 @@ CC_SW_REL := -o3
# ----------------------------------------------------------------------------
# Standard flags for the compiler
# ----------------------------------------------------------------------------
-STD_CC_FLAGS := -q -pdr -pdv -pden -ml3 -mv6400 -d"CHIP_DM642"
+STD_CC_FLAGS := SEDME_DSPFLAGS -d"CHIP_DM642"
# ----------------------------------------------------------------------------
# Standard flags for the compiler when building an executable