summaryrefslogtreecommitdiff
path: root/packages/dsplink/dsplink_1.50.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-05-25 18:36:43 +0000
committerKoen Kooi <koen@openembedded.org>2008-05-25 18:36:43 +0000
commitb7918ae00ce761a1d1d94da0f18e9af274a48b37 (patch)
treeb1be4fa6dabd35ca07ec0c9c4dc9f1dd060cb9ec /packages/dsplink/dsplink_1.50.bb
parent6c9b2ad84da663dd203ac023238318d8254af5a7 (diff)
dsplink: install and package kernel module
* the library is still unpackaged
Diffstat (limited to 'packages/dsplink/dsplink_1.50.bb')
-rw-r--r--packages/dsplink/dsplink_1.50.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/dsplink/dsplink_1.50.bb b/packages/dsplink/dsplink_1.50.bb
index 4f2d7af57a..4e4cc4c29a 100644
--- a/packages/dsplink/dsplink_1.50.bb
+++ b/packages/dsplink/dsplink_1.50.bb
@@ -1,10 +1,12 @@
DESCRIPTION = "DSP Link for TI ARM/DSP processors"
DEPENDS = "virtual/kernel perl-native"
+RDEPENDS = "update-modules"
inherit module-base
PR = "r0"
+PV = "1.50+kernel${KERNEL_VERSION}"
# Get dsplink tarball from TI website, place in sources and calculate
# md5sum
@@ -57,5 +59,25 @@ do_compile () {
oe_runmake -C ${S}/gpp/src all targets
}
+do_install () {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
+ cp ${S}/gpp/BUILD/EXPORT/RELEASE/dsplinkk.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/
+}
+
+pkg_postinst_${PN}-module () {
+ if [ -n "$D" ]; then
+ exit 1
+ fi
+ depmod -a
+ update-modules || true
+}
+
+pkg_postrm_${PN}-module () {
+ update-modules || true
+}
+
+PACKAGES =+ "${PN}-module"
+FILES_${PN}-module = "${sysconfdir} /lib/modules"
+
PACKAGE_ARCH = "${MACHINE_ARCH}"