summaryrefslogtreecommitdiff
path: root/packages/dsplink/dsplink_1.50.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-05-15 17:16:12 +0000
committerKoen Kooi <koen@openembedded.org>2008-05-15 17:16:12 +0000
commit5384da8d9f6a9323eeb30b4110b1deb277f23912 (patch)
tree31dc0925f1e1596e6f944a3b7215049be34987c8 /packages/dsplink/dsplink_1.50.bb
parent1da46e43114e8fea06d3d08f9bd22ef3dd7dd895 (diff)
parentefeb5d474145788e9466d66cd1168c2d6939cd0f (diff)
merge of '3b5a264cff607e4c4977e318dde1e861a664ad81'
and '92366ccb09c8d809619c585c91fe69a2046e1396'
Diffstat (limited to 'packages/dsplink/dsplink_1.50.bb')
-rw-r--r--packages/dsplink/dsplink_1.50.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/packages/dsplink/dsplink_1.50.bb b/packages/dsplink/dsplink_1.50.bb
index a822cf1be4..9d0e1134d8 100644
--- a/packages/dsplink/dsplink_1.50.bb
+++ b/packages/dsplink/dsplink_1.50.bb
@@ -6,8 +6,12 @@ PR = "r0"
# Get dsplink tarball from TI website, place in sources and calculate
# md5sum
-# https://www-a.ti.com/downloads/sds_support/targetcontent/link/index.html
+# Look for tarball at https://www-a.ti.com/downloads/sds_support/targetcontent/link/index.html
+
SRC_URI ="http://install.tarball.in.source.dir/dsplink_1_50.tar.gz \
+file://CURRENTCFG.MK \
+file://c64xx_5.xx_linux.mk \
+file://davinci_mvlpro5.0.mk \
"
S = "${WORKDIR}/dsplink_1_50/dsplink"
@@ -16,10 +20,13 @@ S = "${WORKDIR}/dsplink_1_50/dsplink"
export DSPLINK = "${S}"
do_configure () {
+ cp ${WORKDIR}/CURRENTCFG.MK ${S}/config
+ cp ${WORKDIR}/davinci_mvlpro5.0.mk ${S}/make/Linux
+ cp ${WORKDIR}/c64xx_5.xx_linux.mk ${S}/make/DspBios
}
do_compile () {
-sh ${S}/etc/host/scripts/Linux/buildmodule.sh
+ make -C ${S}/dsplink/gpp/src
}
PACKAGE_ARCH = "${MACHINE_ARCH}"