summaryrefslogtreecommitdiff
path: root/packages/dsplink/dmai_1.20.bb
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2009-02-16 10:03:32 -0500
committerCliff Brake <cbrake@bec-systems.com>2009-02-16 10:03:32 -0500
commitd512927cbf42dc9a3302ecac790a18d397ea012f (patch)
tree2d624d29a763e5f9ae9b618148cfc6063e6cd50e /packages/dsplink/dmai_1.20.bb
parent68e1ea7aeddc4f7efc621558dfd424cd2fe22674 (diff)
parent3fe1150b7afa91ee59dfa6346c1f7387638b7817 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'packages/dsplink/dmai_1.20.bb')
-rw-r--r--packages/dsplink/dmai_1.20.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/packages/dsplink/dmai_1.20.bb b/packages/dsplink/dmai_1.20.bb
new file mode 100644
index 0000000000..12cbea4a12
--- /dev/null
+++ b/packages/dsplink/dmai_1.20.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "Davinci (and OMAP) Multimedia Application Interface"
+DEPENDS = "virtual/kernel codec-engine"
+LICENCE = "unknown"
+
+require ti-paths.inc
+
+# https://www-a.ti.com/downloads/sds_support/applications_packages/dmai/dmai_1_20_00_06/dmai_setuplinux_1_20_00_06.bin
+# Install the above link and put the dmai_1_20_00_06.tar.gz file in the same directory as this recipe
+SRC_URI = "file://dmai_1_20_00_06.tar.gz \
+ file://update-cpu-name.patch;patch=1 \
+ file://update-fb-display.patch;patch=1 \
+ file://update-v4l2-display.patch;patch=1 \
+ file://do-not-panic-on-mixer-failure.patch;patch=1 \
+ file://support-32bit-align.patch;patch=1 \
+# file://resizer-fix.patch;patch=1 \
+ file://built-with-angstrom.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/dmai_1_20_00_06"
+# Yes, the xdc stuff still breaks with a '.' in PWD
+PV = "120"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+TARGET = "all"
+TARGET_neuros-osd2 = " dm6446_al dm6446_db"
+TARGET_beagleboard = " o3530_al"
+
+do_compile() {
+ cd packages/ti/sdo/dmai
+ oe_runmake clean
+ oe_runmake ${TARGET} C_FLAGS="-O2 -I${STAGING_INCDIR}"
+ cd apps
+ oe_runmake clean
+ oe_runmake ${TARGET}
+}
+
+do_install () {
+ oe_runmake install
+}
+
+do_stage () {
+ :
+}