summaryrefslogtreecommitdiff
path: root/packages/docbook-dsssl-stylesheets
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2007-12-31 11:50:13 +0000
committerRobert Schuster <thebohemian@gmx.net>2007-12-31 11:50:13 +0000
commit4875f9bd2c47f8cdc40c5fd70012e262f8be4934 (patch)
tree9ca93b2b8e7c1b6dd091490ad33119df0e4fe4f0 /packages/docbook-dsssl-stylesheets
parent275f358d054ba5c4721cfe87edaec8202ee8095e (diff)
PR 3656
docbook-dsssl-stylesheets-native: New recipe. docbook-sgml-dtd-native: New recipe. docbook-utils-native 0.6.14: Added recipe for new version. docbook-utils 0.6.14: Added recipe for new version. openjade-native: Made functional from native staging location - fixed compilation error opensp-native: Made functional from native staging location. sgml-common-native 0.6.3: Made functional from native staging location. sgml-common 0.6.3: Added pkginstall and pkgpostinstall.
Diffstat (limited to 'packages/docbook-dsssl-stylesheets')
-rw-r--r--packages/docbook-dsssl-stylesheets/.mtn2git_empty0
-rw-r--r--packages/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb35
2 files changed, 35 insertions, 0 deletions
diff --git a/packages/docbook-dsssl-stylesheets/.mtn2git_empty b/packages/docbook-dsssl-stylesheets/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/docbook-dsssl-stylesheets/.mtn2git_empty
diff --git a/packages/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb b/packages/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb
new file mode 100644
index 0000000000..1be79d7cc5
--- /dev/null
+++ b/packages/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "DSSSL stylesheets used to transform SGML and XML DocBook files"
+
+# Simple persmissive
+LICENSE = "DSSSL"
+
+DEPENDS = "sgml-common-native"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/docbook/docbook-dsssl-${PV}.tar.bz2"
+
+S = "${WORKDIR}/docbook-dsssl-${PV}"
+
+inherit native
+
+do_stage () {
+ # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/docbook-dsssl.html
+ # for details.
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 0755 bin/collateindex.pl ${STAGING_BINDIR_NATIVE}
+
+ install -d ${STAGING_DATADIR}/sgml/docbook/dsssl-stylesheets-${PV}
+ install -m 0644 catalog ${STAGING_DATADIR}/sgml/docbook/dsssl-stylesheets-${PV}
+ cp -dpr common ${STAGING_DATADIR}/sgml/docbook/dsssl-stylesheets-${PV}
+
+ install-catalog --add ${sysconfdir}/sgml/dsssl-docbook-stylesheets.cat \
+ ${STAGING_DATADIR}/sgml/docbook/dsssl-stylesheets-${PV}/catalog
+
+ install-catalog --add ${sysconfdir}/sgml/dsssl-docbook-stylesheets.cat \
+ ${STAGING_DATADIR}/sgml/docbook/dsssl-stylesheets-${PV}/common/catalog
+
+ install-catalog --add ${sysconfdir}/sgml/sgml-docbook.cat \
+ ${sysconfdir}/sgml/dsssl-docbook-stylesheets.cat
+
+}
+
+PACKAGES = ""