summaryrefslogtreecommitdiff
path: root/packages/directfb/++dfb_1.0.0.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-06-20 10:33:53 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-06-20 10:33:53 +0000
commitc557c0fa98fc000c0fec2a3db8bd13378705eac0 (patch)
treed11276cb1e776c73adb2b1c65d1579727bb2d7bf /packages/directfb/++dfb_1.0.0.bb
parent0985aab11d4a6ecf875257450b1cb553169fd920 (diff)
directfb update:
* bump ++dfb to 1.0.0 * bump examples to 1.0.0 * bump fusionsound to 1.0.0 * clean up a bit
Diffstat (limited to 'packages/directfb/++dfb_1.0.0.bb')
-rw-r--r--packages/directfb/++dfb_1.0.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/directfb/++dfb_1.0.0.bb b/packages/directfb/++dfb_1.0.0.bb
new file mode 100644
index 0000000000..f440e117ff
--- /dev/null
+++ b/packages/directfb/++dfb_1.0.0.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A C++ Wrapper for the directfb framebuffer library."
+HOMEPAGE = "http://directfb.org"
+SECTION = "libs"
+DEPENDS = "directfb"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.directfb.org/downloads/Extras/++DFB-${PV}.tar.gz"
+S = "${WORKDIR}/++DFB-${PV}"
+RV = "0.9-25"
+
+inherit autotools pkgconfig
+
+do_configure_append() {
+ find ${S} -type f | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+FILES_++dfb_append = " ${libdir}/*.so*"