summaryrefslogtreecommitdiff
path: root/packages/dhcdbd/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/dhcdbd/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/dhcdbd/files')
-rw-r--r--packages/dhcdbd/files/dbus-api-fix.patch20
-rw-r--r--packages/dhcdbd/files/dbus_connection_unref.patch20
-rwxr-xr-xpackages/dhcdbd/files/dhcdbd28
-rw-r--r--packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch26
-rw-r--r--packages/dhcdbd/files/no-ext-options.patch13
-rw-r--r--packages/dhcdbd/files/paths.patch25
6 files changed, 0 insertions, 132 deletions
diff --git a/packages/dhcdbd/files/dbus-api-fix.patch b/packages/dhcdbd/files/dbus-api-fix.patch
deleted file mode 100644
index ce05fc7bf8..0000000000
--- a/packages/dhcdbd/files/dbus-api-fix.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- /tmp/dbus_service.c 2006-08-24 22:09:14.000000000 +0200
-+++ dhcdbd-1.14/dbus_service.c 2006-08-24 22:09:44.228306000 +0200
-@@ -1412,7 +1412,7 @@
- return ( cs );
-
- give_up:
-- dbus_connection_disconnect( connection );
-+ dbus_connection_close( connection );
- dbus_shutdown();
- return ( 0L );
- }
-@@ -1456,7 +1456,7 @@
- cs->roots=0L;
-
-
-- dbus_connection_disconnect( cs->connection );
-+ dbus_connection_close( cs->connection );
- dbus_shutdown();
- free( cs );
- }
diff --git a/packages/dhcdbd/files/dbus_connection_unref.patch b/packages/dhcdbd/files/dbus_connection_unref.patch
deleted file mode 100644
index e34c30b308..0000000000
--- a/packages/dhcdbd/files/dbus_connection_unref.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/src/dbus_service.c.old 2006-11-29 08:32:03.390681525 +0100
-+++ b/src/dbus_service.c 2006-11-29 08:32:18.847562363 +0100
-@@ -1216,7 +1216,7 @@
- return (cs);
-
- give_up:
-- dbus_connection_close(connection);
-+ dbus_connection_unref(connection);
- dbus_shutdown();
-
- return (0L);
-@@ -1250,7 +1250,7 @@
- tdestroy(cs->roots, free_root);
- cs->roots = 0L;
-
-- dbus_connection_close(cs->connection);
-+ dbus_connection_unref(cs->connection);
- dbus_shutdown();
- free(cs);
- }
diff --git a/packages/dhcdbd/files/dhcdbd b/packages/dhcdbd/files/dhcdbd
deleted file mode 100755
index 568753c28c..0000000000
--- a/packages/dhcdbd/files/dhcdbd
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/sh
-#
-# DHCDBD startup script
-
-. /etc/profile
-
-case $1 in
- 'start')
- echo -n "Starting dhcdbd daemon: dhcdbd"
- /sbin/dhcdbd --system
- echo "."
- ;;
-
- 'stop')
- echo -n "Stopping dhcdbd: dhcdbd"
- killall `ps |grep /sbin/dhcdbd | grep -v grep | cut "-d " -f2`
- echo "."
- ;;
-
- 'restart')
- $0 stop
- $0 start
- ;;
-
- *)
- echo "Usage: $0 { start | stop | restart }"
- ;;
-esac
diff --git a/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch b/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch
deleted file mode 100644
index c2e2151d17..0000000000
--- a/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff -Naur dhcdbd-1.14/Makefile dhcdbd-1.14-mod/Makefile
---- dhcdbd-1.14/Makefile 2006-01-17 22:23:51.000000000 +0100
-+++ dhcdbd-1.14-mod/Makefile 2006-08-02 18:02:42.000000000 +0200
-@@ -7,8 +7,8 @@
- LDFLAGS ?= -g
- DESTDIR ?= /
- LIBDIR ?= lib
--DBUS_INCLUDES ?= -I/usr/$(LIBDIR)/dbus-1.0/include -I/usr/include/dbus-1.0
--DBUS_LIBS ?= -ldbus-1
-+DBUS_INCLUDES ?= `pkg-config dbus-1 --cflags`
-+DBUS_LIBS ?= `pkg-config dbus-1 --libs`
- OBJS = dbus_service.o dhcdbd.o dhcp_options.o main.o
- SRCS = dbus_service.c dhcdbd.c dhcp_options.c main.c
- INCS = dbus_service.h dhcdbd.h dhcp_options.h includes.h
-diff -Naur dhcdbd-1.14/tests/Makefile dhcdbd-1.14-mod/tests/Makefile
---- dhcdbd-1.14/tests/Makefile 2006-01-17 22:23:51.000000000 +0100
-+++ dhcdbd-1.14-mod/tests/Makefile 2006-08-02 18:11:43.000000000 +0200
-@@ -2,7 +2,7 @@
- LD = ${CC}
- CFLAGS ?= -g -Wall
- LDFLAGS ?= -g
--DBUS_LIBS ?= -ldbus-1
-+DBUS_LIBS ?= `pkg-config dbus-1 --libs`
-
- all: test_dhcp_options test_dhcdbd_state test_subscriber test_subscriber_dbus test_prospective_subscriber
-
diff --git a/packages/dhcdbd/files/no-ext-options.patch b/packages/dhcdbd/files/no-ext-options.patch
deleted file mode 100644
index 774a2cf140..0000000000
--- a/packages/dhcdbd/files/no-ext-options.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: dhcdbd-2.0/include/dhcdbd.h
-===================================================================
---- dhcdbd-2.0.orig/include/dhcdbd.h 2006-10-18 09:38:18.000000000 +0100
-+++ dhcdbd-2.0/include/dhcdbd.h 2006-10-18 09:38:45.000000000 +0100
-@@ -76,7 +76,7 @@
- #endif
-
- #ifndef DHCLIENT_EXTENDED_OPTION_ENVIRONMENT
--#define DHCLIENT_EXTENDED_OPTION_ENVIRONMENT 1
-+#define DHCLIENT_EXTENDED_OPTION_ENVIRONMENT 0
- #endif
-
- #define DHCDBD_INTERFACE_TEXT "text"
diff --git a/packages/dhcdbd/files/paths.patch b/packages/dhcdbd/files/paths.patch
deleted file mode 100644
index bf547d695c..0000000000
--- a/packages/dhcdbd/files/paths.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/include/dhcdbd.h.orig 2006-08-24 18:34:47.000000000 +0200
-+++ b/include/dhcdbd.h 2006-09-28 19:48:59.000000000 +0200
-@@ -40,11 +40,11 @@
- #endif
-
- #ifndef DHCDBD_DHCLIENT_LEASE_DIR
--#define DHCDBD_DHCLIENT_LEASE_DIR "/var/lib/dhclient/"
-+#define DHCDBD_DHCLIENT_LEASE_DIR "/var/lib/dhcp/"
- #endif
-
- #ifndef DHCDBD_DHCLIENT_LEASE_PFX
--#define DHCDBD_DHCLIENT_LEASE_PFX "dhclient-"
-+#define DHCDBD_DHCLIENT_LEASE_PFX "dhclient."
- #endif
-
- #ifndef DHCDBD_DHCLIENT_LEASE_SFX
-@@ -56,7 +56,7 @@
- #endif
-
- #ifndef DHCDBD_DHCLIENT_PID_PFX
--#define DHCDBD_DHCLIENT_PID_PFX "/var/run/dhclient-"
-+#define DHCDBD_DHCLIENT_PID_PFX "/var/run/dhclient."
- #endif
-
- #ifndef DHCDBD_DHCLIENT_PID_SFX