summaryrefslogtreecommitdiff
path: root/packages/dhcdbd/dhcdbd_3.0.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2008-10-11 13:34:13 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2009-01-13 12:26:15 -0200
commit44b7ac123a781091d48736931a9111f603e62577 (patch)
treead79a07e958d30a7224d2b11619b0d1c480a9205 /packages/dhcdbd/dhcdbd_3.0.bb
parenta459dfb77bd4525e4dc735dcfeb53db8bf7f7bd9 (diff)
dhcdbd: add 3.0
Besides the new version, the required changes to get the initscript properly installer has also been done.
Diffstat (limited to 'packages/dhcdbd/dhcdbd_3.0.bb')
-rw-r--r--packages/dhcdbd/dhcdbd_3.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/dhcdbd/dhcdbd_3.0.bb b/packages/dhcdbd/dhcdbd_3.0.bb
new file mode 100644
index 0000000000..a2467ee921
--- /dev/null
+++ b/packages/dhcdbd/dhcdbd_3.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "DBus-enabled dhcp client"
+SECTION = "net"
+LICENSE = "GPL"
+DEPENDS = "dbus"
+RDEPENDS = "dhcp-client"
+PR = "r1"
+
+SRC_URI = "http://dcantrel.fedorapeople.org/dhcdbd/dhcdbd-${PV}.tar.bz2 \
+ file://dbus_connection_unref.patch;patch=1 \
+ file://paths.patch;patch=1 \
+ file://dhcdbd"
+
+inherit update-rc.d
+
+do_compile() {
+ CC=${TARGET_SYS}-gcc DESTDIR=${prefix} make
+}
+
+do_install() {
+ DESTDIR=${D} make install
+ install -d ${D}/etc/init.d
+ install -m 0755 ${WORKDIR}/dhcdbd ${D}/etc/init.d/
+}
+
+INITSCRIPT_NAME = dhcdbd
+INITSCRIPT_PARAMS = "start 30 2 3 4 5 . stop 30 0 1 6 ."
+FILES_${PN} += "${sysconfdir} ${datadir}/dbus-1 ${base_sbindir}/*"