summaryrefslogtreecommitdiff
path: root/packages/dbus
diff options
context:
space:
mode:
authorKristoffer Ericson <kristoffer_e1@hotmail.com>2006-07-31 15:36:05 +0000
committerKristoffer Ericson <kristoffer_e1@hotmail.com>2006-07-31 15:36:05 +0000
commitcc67256da139ba348bfc5e98138da3d7e84c7f48 (patch)
treea88692987440c7a78c27dfc5ff1aa3cf01223da1 /packages/dbus
parent5e5b590002af02b51b7e39ddb3a18357ce1954c6 (diff)
parent09436056f94e7103d436177bdaea7c3bd9493913 (diff)
merge of 158d7fcc3d3ef86d360c775f912e5e314992018d
and bbd3a2811e13a3b99224c1a846af2a244d292c41
Diffstat (limited to 'packages/dbus')
-rw-r--r--packages/dbus/dbus-0.6x/fix-segfault.patch11
-rw-r--r--packages/dbus/dbus-0.91/.mtn2git_empty0
-rw-r--r--packages/dbus/dbus-0.91/dbus-1.init (renamed from packages/dbus/dbus-0.90/dbus-1.init)0
-rw-r--r--packages/dbus/dbus-0.91/fix-segfault.patch11
-rw-r--r--packages/dbus/dbus-glib-native_0.71.bb22
-rw-r--r--packages/dbus/dbus-glib/dbus-glib-0.70-fix-includes.patch21
-rw-r--r--packages/dbus/dbus-glib_0.71.bb (renamed from packages/dbus/dbus-glib_0.70.bb)1
-rw-r--r--packages/dbus/dbus-native_0.91.bb26
-rw-r--r--packages/dbus/dbus-python/dbus-python-0.70-fix-binary-modules-dir.patch18
-rw-r--r--packages/dbus/dbus-python_0.71.bb (renamed from packages/dbus/dbus-python_0.70.bb)3
-rw-r--r--packages/dbus/dbus_0.62.inc6
-rw-r--r--packages/dbus/dbus_0.91.bb (renamed from packages/dbus/dbus_0.90.bb)5
12 files changed, 79 insertions, 45 deletions
diff --git a/packages/dbus/dbus-0.6x/fix-segfault.patch b/packages/dbus/dbus-0.6x/fix-segfault.patch
new file mode 100644
index 0000000000..de5bcff774
--- /dev/null
+++ b/packages/dbus/dbus-0.6x/fix-segfault.patch
@@ -0,0 +1,11 @@
+--- /tmp/dbus-marshal-recursive.c 2006-07-28 14:58:08.000000000 +0200
++++ dbus-0.90/dbus/dbus-marshal-recursive.c 2006-07-28 14:58:18.724411000 +0200
+@@ -1294,7 +1294,7 @@
+ _dbus_string_get_length (&block->replacement) - block->padding,
+ &fixups))
+ goto oom;
+-
++printf("%s(%d)""got here", __FILE__, __LINE__);
+ #if RECURSIVE_MARSHAL_WRITE_TRACE
+ _dbus_verbose ("REPLACEMENT at padding %d len %d\n", block->padding,
+ _dbus_string_get_length (&block->replacement) - block->padding);
diff --git a/packages/dbus/dbus-0.91/.mtn2git_empty b/packages/dbus/dbus-0.91/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus-0.91/.mtn2git_empty
diff --git a/packages/dbus/dbus-0.90/dbus-1.init b/packages/dbus/dbus-0.91/dbus-1.init
index 60440b7223..60440b7223 100644
--- a/packages/dbus/dbus-0.90/dbus-1.init
+++ b/packages/dbus/dbus-0.91/dbus-1.init
diff --git a/packages/dbus/dbus-0.91/fix-segfault.patch b/packages/dbus/dbus-0.91/fix-segfault.patch
new file mode 100644
index 0000000000..de5bcff774
--- /dev/null
+++ b/packages/dbus/dbus-0.91/fix-segfault.patch
@@ -0,0 +1,11 @@
+--- /tmp/dbus-marshal-recursive.c 2006-07-28 14:58:08.000000000 +0200
++++ dbus-0.90/dbus/dbus-marshal-recursive.c 2006-07-28 14:58:18.724411000 +0200
+@@ -1294,7 +1294,7 @@
+ _dbus_string_get_length (&block->replacement) - block->padding,
+ &fixups))
+ goto oom;
+-
++printf("%s(%d)""got here", __FILE__, __LINE__);
+ #if RECURSIVE_MARSHAL_WRITE_TRACE
+ _dbus_verbose ("REPLACEMENT at padding %d len %d\n", block->padding,
+ _dbus_string_get_length (&block->replacement) - block->padding);
diff --git a/packages/dbus/dbus-glib-native_0.71.bb b/packages/dbus/dbus-glib-native_0.71.bb
new file mode 100644
index 0000000000..81a15c9b35
--- /dev/null
+++ b/packages/dbus/dbus-glib-native_0.71.bb
@@ -0,0 +1,22 @@
+SECTION = "base"
+PR = "r0"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+LICENSE = "GPL"
+DEPENDS = "expat glib-2.0 virtual/libintl dbus-native"
+
+SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-glib-${PV}.tar.gz \
+ file://cross.patch;patch=1"
+
+inherit autotools pkgconfig gettext native
+
+S = "${WORKDIR}/dbus-glib-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-glib"
+DEPENDS = "glib-2.0-native"
+
+do_stage() {
+ oe_runmake install
+ install -d ${STAGING_DATADIR}/dbus
+ install -m 0644 tools/dbus-bus-introspect.xml ${STAGING_DATADIR}/dbus
+ install -m 0644 tools/dbus-glib-bindings.h ${STAGING_DATADIR}/dbus
+}
diff --git a/packages/dbus/dbus-glib/dbus-glib-0.70-fix-includes.patch b/packages/dbus/dbus-glib/dbus-glib-0.70-fix-includes.patch
deleted file mode 100644
index 68edc54038..0000000000
--- a/packages/dbus/dbus-glib/dbus-glib-0.70-fix-includes.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- dbus-glib-0.70/dbus/Makefile.am.fix_includes 2006-07-17 13:00:39.000000000 -0400
-+++ dbus-glib-0.70/dbus/Makefile.am 2006-07-17 20:09:00.000000000 -0400
-@@ -38,13 +38,13 @@
- dbus-gvalue.c \
- dbus-gvalue.h \
- dbus-gthread.c \
-- dbus-glib.h \
-- dbus-glib-lowlevel.h \
-- dbus-glib-error-enum.h \
- $(DBUS_GLIB_INTERNALS)
-
- libdbus_glib_HEADERS = \
-- dbus-gtype-specialized.h
-+ dbus-gtype-specialized.h \
-+ dbus-glib.h \
-+ dbus-glib-lowlevel.h \
-+ dbus-glib-error-enum.h
-
- libdbus_glibdir = $(includedir)/dbus-1.0/dbus
-
-
diff --git a/packages/dbus/dbus-glib_0.70.bb b/packages/dbus/dbus-glib_0.71.bb
index 304e7aca48..6bb69ba316 100644
--- a/packages/dbus/dbus-glib_0.70.bb
+++ b/packages/dbus/dbus-glib_0.71.bb
@@ -7,7 +7,6 @@ DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native"
SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-glib-${PV}.tar.gz \
file://cross.patch;patch=1 \
- file://dbus-glib-0.70-fix-includes.patch;patch=1 \
file://no-examples.patch;patch=1 \
file://no-introspect.patch;patch=1"
diff --git a/packages/dbus/dbus-native_0.91.bb b/packages/dbus/dbus-native_0.91.bb
new file mode 100644
index 0000000000..e176787d91
--- /dev/null
+++ b/packages/dbus/dbus-native_0.91.bb
@@ -0,0 +1,26 @@
+DEFAULT_PREFERENCE="-1"
+
+SECTION = "base"
+PR = "r0"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+LICENSE = "GPL"
+
+S = "${WORKDIR}/dbus-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus"
+DEPENDS = "glib-2.0-native"
+
+SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
+ file://tmpdir.patch;patch=1"
+
+inherit autotools pkgconfig gettext native
+
+EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \
+ --disable-checks --disable-xml-docs --disable-doxygen-docs \
+ --with-xml=expat --without-x"
+
+do_stage () {
+ oe_runmake install
+ autotools_stage_all
+}
diff --git a/packages/dbus/dbus-python/dbus-python-0.70-fix-binary-modules-dir.patch b/packages/dbus/dbus-python/dbus-python-0.70-fix-binary-modules-dir.patch
deleted file mode 100644
index 17b78d938a..0000000000
--- a/packages/dbus/dbus-python/dbus-python-0.70-fix-binary-modules-dir.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- dbus-python-0.70/setup.py.fix-binary-modules-dir 2006-07-17 20:30:07.000000000 -0400
-+++ dbus-python-0.70/setup.py 2006-07-17 20:30:22.000000000 -0400
-@@ -92,12 +92,12 @@
- "dbus/_util",
- ],
- ext_modules=[
-- Extension("dbus_bindings", ["dbus/dbus_bindings.pyx"],
-+ Extension("dbus/dbus_bindings", ["dbus/dbus_bindings.pyx"],
- include_dirs=dbus_includes,
- libraries=["dbus-1"],
-
- ),
-- Extension("dbus_glib_bindings", ["dbus/dbus_glib_bindings.pyx"],
-+ Extension("dbus/dbus_glib_bindings", ["dbus/dbus_glib_bindings.pyx"],
- include_dirs=dbus_glib_includes,
- libraries=["dbus-glib-1", "dbus-1", "glib-2.0"],
- define_macros=[
-
diff --git a/packages/dbus/dbus-python_0.70.bb b/packages/dbus/dbus-python_0.71.bb
index 7bfbc931ed..7c80a1be3c 100644
--- a/packages/dbus/dbus-python_0.70.bb
+++ b/packages/dbus/dbus-python_0.71.bb
@@ -9,7 +9,6 @@ PR = "r0"
DEPENDS = "python-native"
SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-python-${PV}.tar.gz \
- file://cross.patch;patch=1 \
- file://dbus-python-0.70-fix-binary-modules-dir.patch;patch=1"
+ file://cross.patch;patch=1"
inherit distutils
diff --git a/packages/dbus/dbus_0.62.inc b/packages/dbus/dbus_0.62.inc
index c1dcc0e4a3..3b0f24f408 100644
--- a/packages/dbus/dbus_0.62.inc
+++ b/packages/dbus/dbus_0.62.inc
@@ -1,15 +1,19 @@
SECTION = "base"
-PR = "r0"
+PR = "r1"
HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
DESCRIPTION = "message bus system for applications to talk to one another"
LICENSE = "GPL"
DEPENDS = "expat glib-2.0 virtual/libintl"
+
+FILESPATH = "${FILE_DIRNAME}/dbus-0.6x:${FILE_DIRNAME}/dbus"
+
SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-${PV}.tar.gz \
file://cross.patch;patch=1 \
file://tmpdir.patch;patch=1 \
file://dbus-1.init \
file://no-examples.patch;patch=1 \
+ file://fix-segfault.patch;patch=1 \
${SRC_URI_EXTRA}"
inherit autotools pkgconfig update-rc.d gettext
diff --git a/packages/dbus/dbus_0.90.bb b/packages/dbus/dbus_0.91.bb
index e48b09e4ff..9eec6c86c7 100644
--- a/packages/dbus/dbus_0.90.bb
+++ b/packages/dbus/dbus_0.91.bb
@@ -1,7 +1,7 @@
DEFAULT_PREFERENCE="-1"
SECTION = "base"
-PR = "r0"
+PR = "r1"
HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
DESCRIPTION = "message bus system for applications to talk to one another"
LICENSE = "GPL"
@@ -10,7 +10,8 @@ DEPENDS = "expat glib-2.0 virtual/libintl"
SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-${PV}.tar.gz \
file://cross.patch;patch=1 \
file://tmpdir.patch;patch=1 \
- file://dbus-1.init"
+ file://dbus-1.init \
+ file://fix-segfault.patch;patch=1"
inherit autotools pkgconfig update-rc.d gettext