summaryrefslogtreecommitdiff
path: root/packages/dbus/dbus_0.20.bb
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2005-04-02 23:18:59 +0000
committerChris Larson <clarson@kergoth.com>2005-04-02 23:18:59 +0000
commit051dc38192ed40cc675bf66103c1ad4945762899 (patch)
tree102dc4f7a2e7fec9d00e045403494038722b4668 /packages/dbus/dbus_0.20.bb
parent0a5cefea6ad60061171c450332b35202d44c5b1a (diff)
Merge oe-devel@oe-devel.bkbits.net:openembedded
into handhelds.org:/home/kergoth/code/openembedded 2005/04/02 17:30:09-05:00 handhelds.org!kergoth Apply a patch to dbus to make it use the gettext autoconf macros, so that its nls support can be disabled (note that atm it links against libintl anyway, through glib's use of it, since -lintl is in the glib .pc files). BKrev: 424f2863eUcoABD12GDxqIWbMLwsFQ
Diffstat (limited to 'packages/dbus/dbus_0.20.bb')
-rw-r--r--packages/dbus/dbus_0.20.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/dbus/dbus_0.20.bb b/packages/dbus/dbus_0.20.bb
index e69de29bb2..0a08862f10 100644
--- a/packages/dbus/dbus_0.20.bb
+++ b/packages/dbus/dbus_0.20.bb
@@ -0,0 +1,31 @@
+SECTION = "base"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+DEPENDS = "expat glib-2.0 virtual/libintl"
+LICENSE = "GPL"
+
+SRC_URI = "http://freedesktop.org/Software/dbus/releases/dbus-${PV}.tar.gz \
+ file://cross.patch;patch=1"
+
+inherit autotools pkgconfig gettext
+
+EXTRA_OECONF = "--disable-qt --disable-gtk --disable-tests \
+ --disable-checks --disable-xml-docs --disable-doxygen-docs \
+ --with-xml=expat --without-x"
+
+headers = "dbus-address.h dbus-bus.h dbus-connection.h dbus-errors.h dbus-macros.h dbus-memory.h dbus-message.h dbus-pending-call.h dbus-protocol.h dbus-server.h dbus-threads.h dbus-types.h dbus.h"
+
+do_stage () {
+ oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR}
+ oe_libinstall -so -C glib libdbus-glib-1 ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/dbus-1.0/dbus
+ for i in ${headers}; do
+ install -m 0644 dbus/$i ${STAGING_INCDIR}/dbus-1.0/dbus/$i
+ done
+
+ install -m 0644 glib/dbus-glib.h ${STAGING_INCDIR}/dbus-1.0/dbus/
+
+ mkdir -p ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
+ install -m 0644 dbus/dbus-arch-deps.h ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
+}