summaryrefslogtreecommitdiff
path: root/packages/dbus/dbus-native_0.94.bb
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2006-10-14 21:20:53 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2006-10-14 21:20:53 +0000
commitb6820e12f3e8eaccc180aa4dc4e681de6b1306a2 (patch)
treeffc5cf8c34ea412ef404c0c942201aae79456f47 /packages/dbus/dbus-native_0.94.bb
parentdc4a4a7224a5dd4936faa81e25ef1ca442b5e50f (diff)
dbus: add 0.94 (1.0 RC 2)
Diffstat (limited to 'packages/dbus/dbus-native_0.94.bb')
-rw-r--r--packages/dbus/dbus-native_0.94.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/dbus/dbus-native_0.94.bb b/packages/dbus/dbus-native_0.94.bb
new file mode 100644
index 0000000000..2d99c56370
--- /dev/null
+++ b/packages/dbus/dbus-native_0.94.bb
@@ -0,0 +1,28 @@
+SECTION = "base"
+PR = "r0"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+LICENSE = "GPL"
+
+S = "${WORKDIR}/dbus-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus"
+DEPENDS = "glib-2.0-native libxml2-native expat-native"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
+ file://tmpdir.patch;patch=1"
+
+inherit autotools pkgconfig gettext native
+
+EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \
+ --disable-checks --disable-xml-docs --disable-doxygen-docs \
+ --with-xml=expat --without-x"
+
+do_stage () {
+ oe_runmake install
+ autotools_stage_all
+
+ # for dbus-glib-native introspection generation
+ install -d ${STAGING_DATADIR}/dbus
+ install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
+}