summaryrefslogtreecommitdiff
path: root/packages/dbus/dbus-glib_0.74.bb
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-10-07 00:33:28 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-10-07 00:33:28 +0000
commit6e90aae26efa66553063b74b9afa9563b70fb982 (patch)
treedc0273068963d8e57f48f75875e5236153cf1cd9 /packages/dbus/dbus-glib_0.74.bb
parent496d5415774f03b6e09aee17763ac9432d9c2755 (diff)
parent62007cb1fac3e5a7f4a09b61c7d3c3b7cd5fc8a7 (diff)
merge of '55c714e37be4606a4166b3df883d5f404d3889bf'
and 'd714000fc8a6b75093a93f01782724b65d31eac1'
Diffstat (limited to 'packages/dbus/dbus-glib_0.74.bb')
-rw-r--r--packages/dbus/dbus-glib_0.74.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/dbus/dbus-glib_0.74.bb b/packages/dbus/dbus-glib_0.74.bb
new file mode 100644
index 0000000000..3754abb708
--- /dev/null
+++ b/packages/dbus/dbus-glib_0.74.bb
@@ -0,0 +1,28 @@
+SECTION = "base"
+PR = "r0"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+LICENSE = "GPL"
+DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native dbus"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \
+ file://no-examples.patch;patch=1 \
+ file://no-introspect.patch;patch=1"
+
+inherit autotools pkgconfig gettext
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
+
+do_configure_prepend() {
+ install -m 0644 ${STAGING_DIR}/${BUILD_SYS}/share/dbus/dbus-bus-introspect.xml ${S}/tools/
+ install -m 0644 ${STAGING_DIR}/${BUILD_SYS}/share/dbus/dbus-glib-bindings.h ${S}/tools/
+}
+
+do_stage () {
+ oe_libinstall -so -C dbus libdbus-glib-1 ${STAGING_LIBDIR}
+
+ autotools_stage_includes
+}
+
+FILES_${PN}-dev += "${bindir}/dbus-binding-tool"