summaryrefslogtreecommitdiff
path: root/packages/dbus/dbus-glib_0.74.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-09-30 21:03:23 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-09-30 21:03:23 +0000
commit16cbf4ea61c3c1c4b8bd384e27e2bc14cd98c512 (patch)
treeca5ed4fe514a08db4109f64bbb7f9e8e1134bac0 /packages/dbus/dbus-glib_0.74.bb
parent6009c3769647135923e1ce7b1c3617a8073df6ab (diff)
packages/dbus/dbus-glib_0.74.bb : add updated version from poky, remove
older version This will fix networkmanager
Diffstat (limited to 'packages/dbus/dbus-glib_0.74.bb')
-rw-r--r--packages/dbus/dbus-glib_0.74.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/dbus/dbus-glib_0.74.bb b/packages/dbus/dbus-glib_0.74.bb
new file mode 100644
index 0000000000..3754abb708
--- /dev/null
+++ b/packages/dbus/dbus-glib_0.74.bb
@@ -0,0 +1,28 @@
+SECTION = "base"
+PR = "r0"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+LICENSE = "GPL"
+DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native dbus"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \
+ file://no-examples.patch;patch=1 \
+ file://no-introspect.patch;patch=1"
+
+inherit autotools pkgconfig gettext
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
+
+do_configure_prepend() {
+ install -m 0644 ${STAGING_DIR}/${BUILD_SYS}/share/dbus/dbus-bus-introspect.xml ${S}/tools/
+ install -m 0644 ${STAGING_DIR}/${BUILD_SYS}/share/dbus/dbus-glib-bindings.h ${S}/tools/
+}
+
+do_stage () {
+ oe_libinstall -so -C dbus libdbus-glib-1 ${STAGING_LIBDIR}
+
+ autotools_stage_includes
+}
+
+FILES_${PN}-dev += "${bindir}/dbus-binding-tool"