summaryrefslogtreecommitdiff
path: root/packages/dbus/dbus-glib_0.72.bb
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2006-10-27 09:03:57 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2006-10-27 09:03:57 +0000
commit6167e546c495443fa4f0cc2a2aa0cd4fa6a57818 (patch)
treef3fc986f109f706e2ffac1fb54e3d3355d9f2fe7 /packages/dbus/dbus-glib_0.72.bb
parent1e188e5d610e693cbbd8d8716907ceb1897bf8c3 (diff)
dbus-glib: add 0.72
Diffstat (limited to 'packages/dbus/dbus-glib_0.72.bb')
-rw-r--r--packages/dbus/dbus-glib_0.72.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/dbus/dbus-glib_0.72.bb b/packages/dbus/dbus-glib_0.72.bb
new file mode 100644
index 0000000000..641f0263a2
--- /dev/null
+++ b/packages/dbus/dbus-glib_0.72.bb
@@ -0,0 +1,29 @@
+SECTION = "base"
+PR = "r0"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+LICENSE = "GPL"
+DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native dbus"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
+ file://no-examples.patch;patch=1 \
+ file://no-introspect.patch;patch=1"
+
+inherit autotools pkgconfig gettext
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
+
+do_configure_prepend() {
+ install -m 0644 ${STAGING_DIR}/${BUILD_SYS}/share/dbus/dbus-bus-introspect.xml ${S}/tools/
+ install -m 0644 ${STAGING_DIR}/${BUILD_SYS}/share/dbus/dbus-glib-bindings.h ${S}/tools/
+}
+
+do_stage () {
+ oe_libinstall -so -C dbus libdbus-glib-1 ${STAGING_LIBDIR}
+
+ autotools_stage_includes
+}
+
+FILES_${PN}-dev += "${bindir}/dbus-binding-tool"