summaryrefslogtreecommitdiff
path: root/packages/dbus/dbus-glib_0.71.bb
diff options
context:
space:
mode:
authorKristoffer Ericson <kristoffer_e1@hotmail.com>2006-07-31 15:36:05 +0000
committerKristoffer Ericson <kristoffer_e1@hotmail.com>2006-07-31 15:36:05 +0000
commitcc67256da139ba348bfc5e98138da3d7e84c7f48 (patch)
treea88692987440c7a78c27dfc5ff1aa3cf01223da1 /packages/dbus/dbus-glib_0.71.bb
parent5e5b590002af02b51b7e39ddb3a18357ce1954c6 (diff)
parent09436056f94e7103d436177bdaea7c3bd9493913 (diff)
merge of 158d7fcc3d3ef86d360c775f912e5e314992018d
and bbd3a2811e13a3b99224c1a846af2a244d292c41
Diffstat (limited to 'packages/dbus/dbus-glib_0.71.bb')
-rw-r--r--packages/dbus/dbus-glib_0.71.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/dbus/dbus-glib_0.71.bb b/packages/dbus/dbus-glib_0.71.bb
new file mode 100644
index 0000000000..6bb69ba316
--- /dev/null
+++ b/packages/dbus/dbus-glib_0.71.bb
@@ -0,0 +1,29 @@
+SECTION = "base"
+PR = "r0"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+LICENSE = "GPL"
+DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native"
+
+SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-glib-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
+ file://no-examples.patch;patch=1 \
+ file://no-introspect.patch;patch=1"
+
+inherit autotools pkgconfig gettext
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
+
+do_configure_prepend() {
+ install -m 0644 ${STAGING_DIR}/${BUILD_SYS}/share/dbus/dbus-bus-introspect.xml ${S}/tools/
+ install -m 0644 ${STAGING_DIR}/${BUILD_SYS}/share/dbus/dbus-glib-bindings.h ${S}/tools/
+}
+
+do_stage () {
+ oe_libinstall -so -C dbus libdbus-glib-1 ${STAGING_LIBDIR}
+
+ autotools_stage_includes
+}
+
+FILES_${PN}-dev += "${bindir}/dbus-binding-tool"