summaryrefslogtreecommitdiff
path: root/packages/dbus/dbus-0.94
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-12-13 22:28:14 +0000
committerKoen Kooi <koen@openembedded.org>2006-12-13 22:28:14 +0000
commit501bdcb4c3ab3178563bac3f45eed6586f4f7454 (patch)
treef8d0ae1ea23b3052ba2faa747ed6061a4bf88bbb /packages/dbus/dbus-0.94
parent48785a3b7179e9f3385289d4e15216f4c2e5ed3e (diff)
dbus: make Marcin happy:
* create a dbus.inc * remove outdated dbi * remove DEFAULT_PREFERENCE from 1.0.1 * dbus-glib still has both versions since 0.72 doesn't build for me
Diffstat (limited to 'packages/dbus/dbus-0.94')
-rw-r--r--packages/dbus/dbus-0.94/.mtn2git_empty0
-rw-r--r--packages/dbus/dbus-0.94/dbus-1.init86
-rw-r--r--packages/dbus/dbus-0.94/fix-install-daemon.patch13
3 files changed, 0 insertions, 99 deletions
diff --git a/packages/dbus/dbus-0.94/.mtn2git_empty b/packages/dbus/dbus-0.94/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/dbus/dbus-0.94/.mtn2git_empty
+++ /dev/null
diff --git a/packages/dbus/dbus-0.94/dbus-1.init b/packages/dbus/dbus-0.94/dbus-1.init
deleted file mode 100644
index 7ef411606b..0000000000
--- a/packages/dbus/dbus-0.94/dbus-1.init
+++ /dev/null
@@ -1,86 +0,0 @@
-#! /bin/sh
-# -*- coding: utf-8 -*-
-# Debian init.d script for D-BUS
-# Copyright © 2003 Colin Walters <walters@debian.org>
-
-set -e
-
-DAEMON=/usr/bin/dbus-daemon
-NAME=dbus
-DAEMONUSER=messagebus
-PIDDIR=/var/run/dbus
-PIDFILE=$PIDDIR/pid
-DESC="system message bus"
-EVENTDIR=/etc/dbus-1/event.d
-
-test -x $DAEMON || exit 0
-
-# Source defaults file; edit that file to configure this script.
-ENABLED=1
-PARAMS=""
-if [ -e /etc/default/dbus ]; then
- . /etc/default/dbus
-fi
-
-test "$ENABLED" != "0" || exit 0
-
-start_it_up()
-{
- if [ ! -d $PIDDIR ]; then
- mkdir -p $PIDDIR
- chown $DAEMONUSER $PIDDIR
- chgrp $DAEMONUSER $PIDDIR
- fi
- if [ -e $PIDFILE ]; then
- PIDDIR=/proc/$(cat $PIDFILE)
- if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then
- echo "$DESC already started; not starting."
- else
- echo "Removing stale PID file $PIDFILE."
- rm -f $PIDFILE
- fi
- fi
- echo -n "Starting $DESC: "
- start-stop-daemon --start --quiet --pidfile $PIDFILE \
- --user $DAEMONUSER --exec $DAEMON -- --system $PARAMS
- echo "$NAME."
- if [ -d $EVENTDIR ]; then
- run-parts --arg=start $EVENTDIR
- fi
-}
-
-shut_it_down()
-{
- if [ -d $EVENTDIR ]; then
- run-parts --reverse --arg=stop $EVENTDIR
- fi
- echo -n "Stopping $DESC: "
- start-stop-daemon --stop --quiet --pidfile $PIDFILE \
- --user $DAEMONUSER
- # We no longer include these arguments so that start-stop-daemon
- # can do its job even given that we may have been upgraded.
- # We rely on the pidfile being sanely managed
- # --exec $DAEMON -- --system $PARAMS
- echo "$NAME."
- rm -f $PIDFILE
-}
-
-case "$1" in
- start)
- start_it_up
- ;;
- stop)
- shut_it_down
- ;;
- restart|force-reload)
- shut_it_down
- sleep 1
- start_it_up
- ;;
- *)
- echo "Usage: /etc/init.d/$NAME {start|stop|restart|force-reload}" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/packages/dbus/dbus-0.94/fix-install-daemon.patch b/packages/dbus/dbus-0.94/fix-install-daemon.patch
deleted file mode 100644
index c31786357d..0000000000
--- a/packages/dbus/dbus-0.94/fix-install-daemon.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: dbus-0.94/bus/Makefile.am
-===================================================================
---- dbus-0.94.orig/bus/Makefile.am 2006-10-01 17:36:18.000000000 +0200
-+++ dbus-0.94/bus/Makefile.am 2006-10-14 21:40:05.000000000 +0200
-@@ -110,7 +110,7 @@
- $(mkinstalldirs) $(DESTDIR)$(DBUS_DAEMONDIR); \
- chmod 755 $(DESTDIR)$(DBUS_DAEMONDIR); \
- fi
-- $(INSTALL_PROGRAM) dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
-+ $(INSTALL_PROGRAM) .libs/dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
- $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
- $(mkinstalldirs) $(DESTDIR)$(configdir)/system.d
- $(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services