summaryrefslogtreecommitdiff
path: root/packages/cron
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/cron
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/cron')
-rw-r--r--packages/cron/cron-3.0pl1/init38
-rw-r--r--packages/cron/cron-3.0pl1/nonrootinstall.patch28
-rw-r--r--packages/cron/cron-3.0pl1/time.patch16
-rw-r--r--packages/cron/cron_3.0pl1.bb34
4 files changed, 0 insertions, 116 deletions
diff --git a/packages/cron/cron-3.0pl1/init b/packages/cron/cron-3.0pl1/init
deleted file mode 100644
index 0a4f3e256f..0000000000
--- a/packages/cron/cron-3.0pl1/init
+++ /dev/null
@@ -1,38 +0,0 @@
-#! /bin/sh
-#
-# This is an init script for openembedded
-# Copy it to /etc/init.d/cron and type
-# > update-rc.d cron defaults 60
-#
-cron=/usr/sbin/cron
-test -x "$cron" || exit 0
-
-case "$1" in
- start)
- echo -n "Starting Vixie-cron"
- start-stop-daemon --start --quiet --exec $cron
- echo "."
- ;;
- stop)
- echo -n "Stopping Vixie-cron"
- start-stop-daemon --stop --quiet --pidfile /var/run/cron.pid
- echo "."
- ;;
- reload|force-reload)
- start-stop-daemon --stop --quiet --signal 1 --exec $cron
- ;;
- restart)
- echo -n "Stopping Vixie-cron"
- start-stop-daemon --stop --quiet --pidfile /var/run/cron.pid
- echo "."
- sleep 1
- echo -n "Starting Vixie-cron"
- start-stop-daemon --start --quiet --exec $cron
- echo "."
- ;;
- *)
- echo "Usage: /etc/init.d/cron {start|stop|reload|restart|force-reload}"
- exit 1
-esac
-
-exit 0 \ No newline at end of file
diff --git a/packages/cron/cron-3.0pl1/nonrootinstall.patch b/packages/cron/cron-3.0pl1/nonrootinstall.patch
deleted file mode 100644
index e223ba2e6b..0000000000
--- a/packages/cron/cron-3.0pl1/nonrootinstall.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- cron3.0pl1/Makefile~nonrootinstall
-+++ cron3.0pl1/Makefile
-@@ -77,6 +77,9 @@
- #<<the name of the BSD-like install program>>
- #INSTALL = installbsd
- INSTALL = install
-+ifeq ($(DESTDIR),)
-+INSTALLOWN = -o root
-+endif
- #<<any special load flags>>
- LDFLAGS =
- #################################### end configurable stuff
-@@ -113,8 +116,8 @@
- $(CC) $(LDFLAGS) -o crontab $(CRONTAB_OBJ) $(LIBS)
-
- install : all
-- $(INSTALL) -c -m 111 -o root -s cron $(DESTSBIN)/
-- $(INSTALL) -c -m 4111 -o root -s crontab $(DESTBIN)/
-+ $(INSTALL) -c -m 111 $(INSTALLOWN) cron $(DESTSBIN)/
-+ $(INSTALL) -c -m 4111 $(INSTALLOWN) crontab $(DESTBIN)/
- sh putman.sh crontab.1 $(DESTMAN)
- sh putman.sh cron.8 $(DESTMAN)
- sh putman.sh crontab.5 $(DESTMAN)
diff --git a/packages/cron/cron-3.0pl1/time.patch b/packages/cron/cron-3.0pl1/time.patch
deleted file mode 100644
index c172984a85..0000000000
--- a/packages/cron/cron-3.0pl1/time.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- cron3.0pl1/compat.h~time
-+++ cron3.0pl1/compat.h
-@@ -114,7 +114,7 @@
- # define USE_SIGCHLD
- #endif
-
--#if !defined(AIX) && !defined(UNICOS)
-+#if !defined(AIX) && !defined(UNICOS) && !defined(__linux)
- # define SYS_TIME_H 1
- #else
- # define SYS_TIME_H 0
diff --git a/packages/cron/cron_3.0pl1.bb b/packages/cron/cron_3.0pl1.bb
deleted file mode 100644
index f7c2ccc6ba..0000000000
--- a/packages/cron/cron_3.0pl1.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-SECTION = "base"
-DESCRIPTION = "Vixie cron."
-LICENSE = "cron"
-PR ="r8"
-DEPENDS += "install-native"
-
-SRC_URI = "http://ibiblio.org/pub/Linux/system/daemons/cron/cron${PV}.tar.gz \
- file://nonrootinstall.patch;patch=1 \
- file://time.patch;patch=1 \
- file://init"
-S = "${WORKDIR}/cron${PV}"
-
-INITSCRIPT_NAME = "cron"
-INITSCRIPT_PARAMS = "defaults"
-inherit update-rc.d
-
-CFLAGS_append = " -I${S} -DSYS_TIME_H=0"
-do_install () {
- install -d ${D}${sbindir} ${D}${bindir}
- install -d ${D}${sysconfdir}/init.d/
- install -d ${D}/var/cron/tabs
- install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/cron
- oe_runmake 'DESTDIR=${D}' install
- chmod ugo+rx ${D}${sbindir}/* ${D}${bindir}/*
-}
-pkg_postinst() {
- update-rc.d cron defaults 65
-}
-
-pkg_postrm() {
- update-rc.d cron remove
-}
-
-