summaryrefslogtreecommitdiff
path: root/packages/cron/cron_3.0pl1.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-01 02:39:15 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-01 02:39:15 +0000
commit81165fc75e4aeaf9bf959c3cc969c4a2d94f2d44 (patch)
tree1c9ee524e6b01a3ddef6bc90b9a40be894b60f76 /packages/cron/cron_3.0pl1.bb
parent69eadb671ec76da36d35e3e83cd5020ce78da0c7 (diff)
Cron changes from repvik.
Includes a working init script and a working install (the shell script install is used to handle the -s in the makefile).
Diffstat (limited to 'packages/cron/cron_3.0pl1.bb')
-rw-r--r--packages/cron/cron_3.0pl1.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/packages/cron/cron_3.0pl1.bb b/packages/cron/cron_3.0pl1.bb
index bca3f89180..4e13d4c2c1 100644
--- a/packages/cron/cron_3.0pl1.bb
+++ b/packages/cron/cron_3.0pl1.bb
@@ -1,15 +1,23 @@
SECTION = "base"
DESCRIPTION = "Vixie cron."
LICENSE = "cron"
+PR="r3"
SRC_URI = "http://ibiblio.org/pub/Linux/system/daemons/cron/cron${PV}.tar.gz \
file://nonrootinstall.patch;patch=1 \
- file://time.patch;patch=1"
+ file://time.patch;patch=1 \
+ file://install-sh \
+ file://init"
S = "${WORKDIR}/cron${PV}"
CFLAGS_append = " -I${S} -DSYS_TIME_H=0"
do_install () {
install -d ${D}${sbindir} ${D}${bindir}
- oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}/var/cron/tabs
+ install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/cron
+ # This will make the -s option work somewhat portably cross
+ # platform
+ STRIPPROG="$STRIP" oe_runmake 'DESTDIR=${D}' INSTALL="${WORKDIR}/install-sh" install
chmod ugo+rx ${D}${sbindir}/* ${D}${bindir}/*
}