summaryrefslogtreecommitdiff
path: root/packages/coreutils/coreutils-5.3.0
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-09-27 19:53:10 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-27 19:53:10 +0000
commite566d295206aee879254c8c1e81879298d7a2278 (patch)
treeec80fd40a6599430ee69cfda67fb33aa9478dcff /packages/coreutils/coreutils-5.3.0
parentf844e030fa24adf8f2dbb8d209901b96b42d894e (diff)
added coreutils 5.3.0
Diffstat (limited to 'packages/coreutils/coreutils-5.3.0')
-rw-r--r--packages/coreutils/coreutils-5.3.0/.mtn2git_empty0
-rw-r--r--packages/coreutils/coreutils-5.3.0/install-cross.patch27
-rw-r--r--packages/coreutils/coreutils-5.3.0/man.patch42
3 files changed, 69 insertions, 0 deletions
diff --git a/packages/coreutils/coreutils-5.3.0/.mtn2git_empty b/packages/coreutils/coreutils-5.3.0/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/coreutils/coreutils-5.3.0/.mtn2git_empty
diff --git a/packages/coreutils/coreutils-5.3.0/install-cross.patch b/packages/coreutils/coreutils-5.3.0/install-cross.patch
new file mode 100644
index 0000000000..98ba3d916c
--- /dev/null
+++ b/packages/coreutils/coreutils-5.3.0/install-cross.patch
@@ -0,0 +1,27 @@
+--- src/install.c~ 2003-08-09 18:46:45.000000000 +0100
++++ src/install.c 2004-03-27 18:38:45.000000000 +0000
+@@ -516,7 +516,14 @@
+ strip (const char *path)
+ {
+ int status;
+- pid_t pid = fork ();
++ pid_t pid;
++ char *strip_name;
++
++ strip_name = getenv ("STRIP");
++ if (strip_name == NULL)
++ strip_name = "strip";
++
++ pid = fork ();
+
+ switch (pid)
+ {
+@@ -524,7 +531,7 @@
+ error (EXIT_FAILURE, errno, _("fork system call failed"));
+ break;
+ case 0: /* Child. */
+- execlp ("strip", "strip", path, NULL);
++ execlp (strip_name, "strip", path, NULL);
+ error (EXIT_FAILURE, errno, _("cannot run strip"));
+ break;
+ default: /* Parent. */
diff --git a/packages/coreutils/coreutils-5.3.0/man.patch b/packages/coreutils/coreutils-5.3.0/man.patch
new file mode 100644
index 0000000000..5060e4fdff
--- /dev/null
+++ b/packages/coreutils/coreutils-5.3.0/man.patch
@@ -0,0 +1,42 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- coreutils-5.3.0/configure.ac~man
++++ coreutils-5.3.0/configure.ac
+@@ -237,6 +237,20 @@
+ AM_GNU_GETTEXT([external], [need-ngettext])
+ AM_GNU_GETTEXT_VERSION(0.13.1)
+
++AC_MSG_CHECKING([whether to build man pages])
++AC_ARG_WITH(manpages,
++ AS_HELP_STRING([--with-manpages],
++ [Enable building of manpages (default=yes)]),
++ [cu_cv_build_manpages=$enableval],
++ [cu_cv_build_manpages=yes])
++# help2man doesn't work when crosscompiling, as it needs to run the
++# binary that was built.
++if test x"$cross_compiling" = x"yes"; then
++ cu_cv_build_manpages=no
++fi
++AC_MSG_RESULT($cu_cv_build_manpages)
++AM_CONDITIONAL(ENABLE_MANPAGES, test x"$cu_cv_build_manpages" = x"yes")
++
+ AC_CONFIG_FILES(
+ Makefile
+ doc/Makefile
+--- coreutils-5.3.0/Makefile.am~man
++++ coreutils-5.3.0/Makefile.am
+@@ -1,6 +1,11 @@
+ ## Process this file with automake to produce Makefile.in -*-Makefile-*-
+
++if ENABLE_MANPAGES
+ SUBDIRS = lib src doc man po tests
++else
++SUBDIRS = lib src doc po tests
++endif
++
+ EXTRA_DIST = Makefile.cfg Makefile.maint GNUmakefile \
+ .kludge-stamp .prev-version THANKS-to-translators THANKStt.in \
+ .x-sc_space_tab .x-sc_sun_os_names \