summaryrefslogtreecommitdiff
path: root/packages/contacts
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-03-23 22:18:27 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-23 22:18:27 +0000
commit31df77eaae327db13c5e02dccdccfe00c73b86d3 (patch)
tree5b69abe190d71e632a039e3f730084c816e33339 /packages/contacts
parentadd1f30f47d4ed16ddcd0c8a8b4f60a40b1b6273 (diff)
contacts: Sync with poky and fix icons issue
Diffstat (limited to 'packages/contacts')
-rw-r--r--packages/contacts/contacts_0.1.bb22
-rw-r--r--packages/contacts/contacts_svn.bb25
2 files changed, 15 insertions, 32 deletions
diff --git a/packages/contacts/contacts_0.1.bb b/packages/contacts/contacts_0.1.bb
index aff86a1c65..cf025259f2 100644
--- a/packages/contacts/contacts_0.1.bb
+++ b/packages/contacts/contacts_0.1.bb
@@ -3,30 +3,22 @@ SECTION = "x11"
DEPENDS = "glib-2.0 gtk+ libglade eds-dbus"
MAINTAINER = "Chris Lord <chris@openedhand.com>"
DESCRIPTION = "Contacts is an address-book application."
+PR = "r1"
SRC_URI = "svn://svn.o-hand.com/repos/${PN}/tags;module=release-0.1;proto=http \
file://stock_contact.png \
- file://stock_person.png \
- file://index.theme"
+ file://stock_person.png"
inherit autotools pkgconfig
S = "${WORKDIR}/release-0.1"
do_install_append () {
- install -d ${D}/${datadir}/icons/hicolor/48x48/stock/net
- install -d ${D}/${datadir}/icons/hicolor/48x48/stock/generic
-
- install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/icons/hicolor/48x48/stock/net
- install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/icons/hicolor/48x48/stock/generic
- install -m 0644 ${WORKDIR}/index.theme ${D}/${datadir}/icons/hicolor
+ install -d ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/pixmaps
}
-FILES_${PN} += "${datadir}/icons/hicolor/48x48/apps/oh-contacts.png \
- ${datadir}/icons/hicolor/48x48/stock/*/*.png \
- ${datadir}/icons/hicolor/index.theme"
-
-pkg_postinst_${PN} () {
- gtk-update-icon-cache /usr/share/icons/hicolor
-}
+FILES_${PN} += "${datadir}/pixmaps/stock_contact.png \
+ ${datadir}/pixmaps/stock_person.png"
diff --git a/packages/contacts/contacts_svn.bb b/packages/contacts/contacts_svn.bb
index f73c52f857..cd4f6a7836 100644
--- a/packages/contacts/contacts_svn.bb
+++ b/packages/contacts/contacts_svn.bb
@@ -3,16 +3,15 @@ SECTION = "x11"
DEPENDS = "glib-2.0 gtk+ libglade eds-dbus gnome-vfs"
RDEPENDS = "gnome-vfs-plugin-file"
RRECOMMENDS = "gnome-vfs-plugin-http"
-MAINTAINER = "Richard Purdie <richard@openedhand.com>"
+MAINTAINER = "Chris Lord <chris@openedhand.com>"
DESCRIPTION = "Contacts is an address-book application."
-PR = "r3"
+PR = "r5"
PV = "0.1+svn${SRCDATE}"
SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
file://stock_contact.png \
- file://stock_person.png \
- file://index.theme"
+ file://stock_person.png"
inherit autotools pkgconfig
@@ -21,19 +20,11 @@ S = "${WORKDIR}/trunk"
EXTRA_OECONF = "--enable-gnome-vfs"
do_install_append () {
- install -d ${D}/${datadir}/icons/hicolor/48x48/stock/net
- install -d ${D}/${datadir}/icons/hicolor/48x48/stock/generic
-
- install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/icons/hicolor/48x48/stock/net
- install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/icons/hicolor/48x48/stock/generic
- install -m 0644 ${WORKDIR}/index.theme ${D}/${datadir}/icons/hicolor
+ install -d ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/pixmaps
}
-FILES_${PN} += "${datadir}/icons/hicolor/48x48/apps/oh-contacts.png \
- ${datadir}/icons/hicolor/48x48/stock/*/*.png \
- ${datadir}/icons/hicolor/index.theme"
-
-pkg_postinst_${PN} () {
- gtk-update-icon-cache /usr/share/icons/hicolor
-}
+FILES_${PN} += "${datadir}/pixmaps/stock_contact.png \
+ ${datadir}/pixmaps/stock_person.png"