summaryrefslogtreecommitdiff
path: root/packages/contacts/contacts_0.1.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-01-20 12:38:51 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-20 12:38:51 +0000
commitf73f848a11ce5fdee03be4b8c35e5ceb99ca6452 (patch)
tree34cb86550e27bb73d19acdec762ae61b1b8efa7e /packages/contacts/contacts_0.1.bb
parent6c2be5d64959bebc48277bc933c3a9ab96c8fe51 (diff)
Add contacts 0.1 and svn versions
Diffstat (limited to 'packages/contacts/contacts_0.1.bb')
-rw-r--r--packages/contacts/contacts_0.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/contacts/contacts_0.1.bb b/packages/contacts/contacts_0.1.bb
new file mode 100644
index 0000000000..aff86a1c65
--- /dev/null
+++ b/packages/contacts/contacts_0.1.bb
@@ -0,0 +1,32 @@
+LICENSE = "LGPL"
+SECTION = "x11"
+DEPENDS = "glib-2.0 gtk+ libglade eds-dbus"
+MAINTAINER = "Chris Lord <chris@openedhand.com>"
+DESCRIPTION = "Contacts is an address-book application."
+
+SRC_URI = "svn://svn.o-hand.com/repos/${PN}/tags;module=release-0.1;proto=http \
+ file://stock_contact.png \
+ file://stock_person.png \
+ file://index.theme"
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/release-0.1"
+
+do_install_append () {
+ install -d ${D}/${datadir}/icons/hicolor/48x48/stock/net
+ install -d ${D}/${datadir}/icons/hicolor/48x48/stock/generic
+
+ install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/icons/hicolor/48x48/stock/net
+ install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/icons/hicolor/48x48/stock/generic
+ install -m 0644 ${WORKDIR}/index.theme ${D}/${datadir}/icons/hicolor
+}
+
+FILES_${PN} += "${datadir}/icons/hicolor/48x48/apps/oh-contacts.png \
+ ${datadir}/icons/hicolor/48x48/stock/*/*.png \
+ ${datadir}/icons/hicolor/index.theme"
+
+pkg_postinst_${PN} () {
+ gtk-update-icon-cache /usr/share/icons/hicolor
+}
+