summaryrefslogtreecommitdiff
path: root/packages/console-tools/console-tools_0.3.2.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-02-07 17:03:23 -0800
committerKhem Raj <raj.khem@gmail.com>2009-02-07 17:03:23 -0800
commit8a022299d8cbe2de444669a5a25b1f1c182d86f2 (patch)
tree0801f6ef6d9ccf2edbfc67a10efa10ffd611df8f /packages/console-tools/console-tools_0.3.2.bb
parentff830a30aca98928bcd5ea6726e3b3064785f506 (diff)
parentd6bc6a6e31509a9175bdb3636b3fbed89f794986 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'packages/console-tools/console-tools_0.3.2.bb')
-rw-r--r--packages/console-tools/console-tools_0.3.2.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/packages/console-tools/console-tools_0.3.2.bb b/packages/console-tools/console-tools_0.3.2.bb
index 1a02827021..9e48c2c572 100644
--- a/packages/console-tools/console-tools_0.3.2.bb
+++ b/packages/console-tools/console-tools_0.3.2.bb
@@ -1,7 +1,7 @@
SECTION = "base"
LICENSE = "GPL"
DESCRIPTION = "Allows you to set-up and manipulate the Linux console."
-PR = "r3"
+PR = "r4"
SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
file://codepage.patch;patch=1 \
@@ -32,17 +32,20 @@ do_install () {
mv ${D}${bindir}/chvt ${D}${bindir}/chvt.${PN}
mv ${D}${bindir}/deallocvt ${D}${bindir}/deallocvt.${PN}
mv ${D}${bindir}/openvt ${D}${bindir}/openvt.${PN}
+ mv ${D}${bindir}/showkey ${D}${bindir}/showkey.${PN}
}
pkg_postinst_${PN} () {
update-alternatives --install ${bindir}/chvt chvt chvt.${PN} 100
update-alternatives --install ${bindir}/deallocvt deallocvt deallocvt.${PN} 100
update-alternatives --install ${bindir}/openvt openvt openvt.${PN} 100
+ update-alternatives --install ${bindir}/showkey showkey showkey.${PN} 100
}
pkg_prerm_${PN} () {
update-alternatives --remove chvt chvt.${PN}
update-alternatives --remove deallocvt deallocvt.${PN}
update-alternatives --remove openvt openvt.${PN}
+ update-alternatives --remove showkey showkey.${PN}
}