summaryrefslogtreecommitdiff
path: root/packages/connman/connman_git.bb
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2008-12-07 02:30:46 +0100
committerStefan Schmidt <stefan@datenfreihafen.org>2008-12-07 02:30:46 +0100
commite533cf2ca6eb03eb641ca54553b8fbb3c8390ef1 (patch)
treeea058624838ec87785d103625aeea26400d4bac4 /packages/connman/connman_git.bb
parent332c3ff017430b453bf6ff645d3568216a90bad0 (diff)
connman: Add the 0.1 "Nikolaus" release
* Factor out common bits from the git and the 0.1 recipe into .inc * Add checksum for the release tarball * DEFAULT_PREFERENCE = "-1" in the 0.1 recipe for now. Needs more testing and perhaps packaging tweaks
Diffstat (limited to 'packages/connman/connman_git.bb')
-rw-r--r--packages/connman/connman_git.bb43
1 files changed, 2 insertions, 41 deletions
diff --git a/packages/connman/connman_git.bb b/packages/connman/connman_git.bb
index bc5840fb4c..f22125e16e 100644
--- a/packages/connman/connman_git.bb
+++ b/packages/connman/connman_git.bb
@@ -1,50 +1,11 @@
-HOMEPAGE = "http://www.moblin.org/projects/projects_connman.php"
-SUMMARY = "Moblin Connection Manager"
+require connman.inc
PV = "0.0+gitr${SRCREV}"
PR = "r4.02"
PE = "1"
S = "${WORKDIR}/git"
-LICENSE = "GPL"
-DEPENDS = "libgdbus dbus glib-2.0 hal"
-RDEPENDS = "dhcp-client wpa-supplicant resolvconf"
-
-EXTRA_OECONF += " \
- ac_cv_path_WPASUPPLICANT=/usr/sbin/wpa_supplicant \
- ac_cv_path_DHCLIENT=/sbin/dhclient "
+DEPENDS += "libgdbus hal"
SRC_URI = "git://git.moblin.org/repos/projects/connman.git;protocol=http \
file://use_nm_in_cross_compiling.patch;patch=1\
file://connman "
-
-INITSCRIPT_NAME = "connman"
-INITSCRIPT_PARAMS = "defaults 22"
-
-inherit autotools pkgconfig update-rc.d
-
-do_install_append() {
- install -m 0755 ${WORKDIR}/connman ${D}${sysconfdir}/init.d/connman
-}
-
-PACKAGES_DYNAMIC = "${PN}-plugin-*"
-PACKAGES += "${PN}-script-dhclient"
-FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*.so.* \
- ${sysconfdir} ${sharedstatedir} ${localstatedir} \
- ${base_bindir}/* ${base_sbindir}/* ${base_libdir}/*.so* ${datadir}/${PN} \
- ${datadir}/pixmaps ${datadir}/applications \
- ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
- ${libdir}/bonobo/servers \
- ${datadir}/dbus-1/system-services/*"
-FILES_${PN}-script-dhclient += "${libdir}/connman/scripts/dhclient*"
-FILES_${PN}-dbg += "${libdir}/connman/plugins/.debug \
- ${libdir}/connman/scripts/.debug"
-
-python populate_packages_prepend() {
- plugin_dir = bb.data.expand('${libdir}/connman/plugins/', d)
- plugin_name = bb.data.expand('${PN}-plugin-%s', d)
- do_split_packages(d, plugin_dir, '^(.*).so$', plugin_name, '${PN} plugin for %s', extra_depends='' )
-}
-
-do_stage() {
- autotools_stage_all
-}