summaryrefslogtreecommitdiff
path: root/packages/cherokee/cherokee-0.5.5
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-11-19 01:27:18 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-11-19 01:27:18 +0000
commit748434df4dfe66d674fc9acf78baa593a70437ba (patch)
treef4cb5f7d5dc6322ea23f2e8ba2de94df763da88b /packages/cherokee/cherokee-0.5.5
parent2380fca3a354471ea5c8a396732b67d1d1257a54 (diff)
cherokee 0.5.5: Add version 0.5.5 which fixes a large number of bugs
and improves performance a lot. My requirement was for authentication on the root of the site which was unsupported in earlier releases. This version patches the configure input files, unlike the previous version which patched the output files. Tested on i486 and sh4.
Diffstat (limited to 'packages/cherokee/cherokee-0.5.5')
-rw-r--r--packages/cherokee/cherokee-0.5.5/.mtn2git_empty0
-rw-r--r--packages/cherokee/cherokee-0.5.5/Makefile.am.patch26
-rw-r--r--packages/cherokee/cherokee-0.5.5/configure.in.patch52
3 files changed, 78 insertions, 0 deletions
diff --git a/packages/cherokee/cherokee-0.5.5/.mtn2git_empty b/packages/cherokee/cherokee-0.5.5/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/cherokee/cherokee-0.5.5/.mtn2git_empty
diff --git a/packages/cherokee/cherokee-0.5.5/Makefile.am.patch b/packages/cherokee/cherokee-0.5.5/Makefile.am.patch
new file mode 100644
index 0000000000..168200c476
--- /dev/null
+++ b/packages/cherokee/cherokee-0.5.5/Makefile.am.patch
@@ -0,0 +1,26 @@
+Index: cherokee-0.5.5/cget/Makefile.am
+===================================================================
+--- cherokee-0.5.5.orig/cget/Makefile.am
++++ cherokee-0.5.5/cget/Makefile.am
+@@ -12,6 +12,8 @@ $(LARGEFILE_CFLAGS)
+
+ cget_LDADD = \
+ ../cherokee/libcherokee-client.la \
++../cherokee/libcherokee-base.la \
++../cherokee/libcherokee-server.la \
+ $(TLS_LIBS) \
+ $(PTHREAD_LIBS) \
+ $(PTHREAD_CFLAGS)
+Index: cherokee-0.5.5/cherokee/Makefile.am
+===================================================================
+--- cherokee-0.5.5.orig/cherokee/Makefile.am
++++ cherokee-0.5.5/cherokee/Makefile.am
+@@ -923,7 +923,7 @@ cherokee_logrotate_LDADD = libcherokee-b
+ noinst_PROGRAMS = cherokee_admin
+
+ cherokee_admin_SOURCES = cherokee_admin.c
+-cherokee_admin_LDADD = libcherokee-config.la libcherokee-base.la libcherokee-client.la
++cherokee_admin_LDADD = libcherokee-config.la libcherokee-base.la libcherokee-client.la libcherokee-server.la
+
+ ##cherokee_table_test_SOURCES = cherokee_table_test.c
+ ##cherokee_table_test_LDADD = libcherokee.la
diff --git a/packages/cherokee/cherokee-0.5.5/configure.in.patch b/packages/cherokee/cherokee-0.5.5/configure.in.patch
new file mode 100644
index 0000000000..7017243222
--- /dev/null
+++ b/packages/cherokee/cherokee-0.5.5/configure.in.patch
@@ -0,0 +1,52 @@
+Add cache support for some values which require running on the
+target. These need to be set in the site files:
+
+ cherokee_cv_have_epoll
+ cherokee_cv_func_sendfile_works
+
+Both should be set to yes for any reasonably recent linux.
+
+Index: cherokee-0.5.5/configure.in
+===================================================================
+--- cherokee-0.5.5.orig/configure.in
++++ cherokee-0.5.5/configure.in
+@@ -280,6 +280,7 @@ have_epoll=no
+ if test "x$have_epoll_include" = "xyes"; then
+ AC_MSG_CHECKING(for epoll system call)
+
++ AC_CACHE_CHECK([for epoll],cherokee_cv_have_epoll,[
+ AC_TRY_RUN([
+ #include <stdint.h>
+ #include <sys/param.h>
+@@ -297,8 +298,7 @@ if test "x$have_epoll_include" = "xyes";
+ epfd = epoll_create(256);
+ exit (epfd == -1 ? 1 : 0);
+ }
+- ], have_epoll=yes)
+- AC_MSG_RESULT($have_epoll)
++ ], have_epoll=yes)])
+ fi
+
+ dnl
+@@ -625,16 +625,16 @@ ETR_SOCKET_NSL
+ SENDFILE_CHECK
+
+ # Is sendfile broken?
+-AC_MSG_CHECKING(if sendfile works)
++AC_CACHE_CHECK([if sendfile works],cherokee_cv_func_sendfile_works,[
+ AC_TRY_RUN([#include <errno.h>
+ int main() {
+ int o = 0;
+ if (-1 == sendfile(0, 0, &o, 0) && errno == ENOSYS) return -1;
+ return 0;
+- } ],
+- AC_MSG_RESULT(yes),
+- [ AC_MSG_RESULT(no)
+- AC_DEFINE([HAVE_SENDFILE_BROKEN], [1], [broken sendfile]) ])
++ } ], cherokee_cv_func_sendfile_works=yes,cherokee_cv_func_sendfile_works=no,cherokee_cv_func_sendfile_works=false)])
++if test "$cherokee_cv_func_sendfile_works" = false; then
++ AC_DEFINE([HAVE_SENDFILE_BROKEN], [1], [broken sendfile])
++fi
+
+ # readdir_r()
+ LIBWWW_READDIR_R_TYPE