summaryrefslogtreecommitdiff
path: root/packages/cherokee/cherokee-0.5.5/configure.in.patch
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2006-11-19 02:30:21 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2006-11-19 02:30:21 +0000
commit8ef918529299c6afd2eb792b5e5266a1895855b7 (patch)
tree620b398f0a39d22c519e639ae5b8f708273fbd20 /packages/cherokee/cherokee-0.5.5/configure.in.patch
parentdbfde8f842b65ccfd7bf929e9660c7305e30764b (diff)
parent705af44f03163fb7002ce1a2255b4f23e87b1f73 (diff)
merge of '7dc2fd459da1e96fc61fd1b7bc439f0282c91306'
and 'e853ab6b84bda472e6268c922f1ac797be81351c'
Diffstat (limited to 'packages/cherokee/cherokee-0.5.5/configure.in.patch')
-rw-r--r--packages/cherokee/cherokee-0.5.5/configure.in.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/packages/cherokee/cherokee-0.5.5/configure.in.patch b/packages/cherokee/cherokee-0.5.5/configure.in.patch
new file mode 100644
index 0000000000..7017243222
--- /dev/null
+++ b/packages/cherokee/cherokee-0.5.5/configure.in.patch
@@ -0,0 +1,52 @@
+Add cache support for some values which require running on the
+target. These need to be set in the site files:
+
+ cherokee_cv_have_epoll
+ cherokee_cv_func_sendfile_works
+
+Both should be set to yes for any reasonably recent linux.
+
+Index: cherokee-0.5.5/configure.in
+===================================================================
+--- cherokee-0.5.5.orig/configure.in
++++ cherokee-0.5.5/configure.in
+@@ -280,6 +280,7 @@ have_epoll=no
+ if test "x$have_epoll_include" = "xyes"; then
+ AC_MSG_CHECKING(for epoll system call)
+
++ AC_CACHE_CHECK([for epoll],cherokee_cv_have_epoll,[
+ AC_TRY_RUN([
+ #include <stdint.h>
+ #include <sys/param.h>
+@@ -297,8 +298,7 @@ if test "x$have_epoll_include" = "xyes";
+ epfd = epoll_create(256);
+ exit (epfd == -1 ? 1 : 0);
+ }
+- ], have_epoll=yes)
+- AC_MSG_RESULT($have_epoll)
++ ], have_epoll=yes)])
+ fi
+
+ dnl
+@@ -625,16 +625,16 @@ ETR_SOCKET_NSL
+ SENDFILE_CHECK
+
+ # Is sendfile broken?
+-AC_MSG_CHECKING(if sendfile works)
++AC_CACHE_CHECK([if sendfile works],cherokee_cv_func_sendfile_works,[
+ AC_TRY_RUN([#include <errno.h>
+ int main() {
+ int o = 0;
+ if (-1 == sendfile(0, 0, &o, 0) && errno == ENOSYS) return -1;
+ return 0;
+- } ],
+- AC_MSG_RESULT(yes),
+- [ AC_MSG_RESULT(no)
+- AC_DEFINE([HAVE_SENDFILE_BROKEN], [1], [broken sendfile]) ])
++ } ], cherokee_cv_func_sendfile_works=yes,cherokee_cv_func_sendfile_works=no,cherokee_cv_func_sendfile_works=false)])
++if test "$cherokee_cv_func_sendfile_works" = false; then
++ AC_DEFINE([HAVE_SENDFILE_BROKEN], [1], [broken sendfile])
++fi
+
+ # readdir_r()
+ LIBWWW_READDIR_R_TYPE