summaryrefslogtreecommitdiff
path: root/packages/busybox
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2006-02-25 09:17:02 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-25 09:17:02 +0000
commit093295ccf292b34e7a9a5d4a5bc5a5198e1c5853 (patch)
tree5b3184d2c015a1724a00cb03825144b8a393d221 /packages/busybox
parentf64674d824f94bfac71bc9768e7052614a1a41d8 (diff)
Add sysctl applet to slugos
Diffstat (limited to 'packages/busybox')
-rw-r--r--packages/busybox/busybox-1.01/slugos/defconfig2
-rw-r--r--packages/busybox/busybox-1.01/slugos/sysctl.conf29
-rw-r--r--packages/busybox/busybox_1.01.bb8
3 files changed, 37 insertions, 2 deletions
diff --git a/packages/busybox/busybox-1.01/slugos/defconfig b/packages/busybox/busybox-1.01/slugos/defconfig
index 7eca339d2d..55aa5f3b5e 100644
--- a/packages/busybox/busybox-1.01/slugos/defconfig
+++ b/packages/busybox/busybox-1.01/slugos/defconfig
@@ -353,7 +353,7 @@ CONFIG_RENICE=y
CONFIG_TOP=y
FEATURE_CPU_USAGE_PERCENTAGE=y
CONFIG_UPTIME=y
-# CONFIG_SYSCTL is not set
+CONFIG_SYSCTL=y
#
# Another Bourne-like Shell
diff --git a/packages/busybox/busybox-1.01/slugos/sysctl.conf b/packages/busybox/busybox-1.01/slugos/sysctl.conf
new file mode 100644
index 0000000000..9f913dec96
--- /dev/null
+++ b/packages/busybox/busybox-1.01/slugos/sysctl.conf
@@ -0,0 +1,29 @@
+#
+# /etc/sysctl.conf - Configuration file for setting system variables
+# See sysctl.conf (5) for information.
+#
+
+#kernel.domainname = example.com
+
+# This flag allows the machine to respond to broadcast pings.
+# Very useful on embedded machines
+net/ipv4/icmp_echo_ignore_broadcasts=0
+
+# Uncomment the following to stop low-level messages on console
+#kernel/printk = 4 4 1 7
+
+##############################################################3
+# Functions previously found in netbase
+#
+
+# Uncomment the next line to enable Spoof protection (reverse-path filter)
+#net/ipv4/conf/all/rp_filter=1
+
+# Uncomment the next line to enable TCP/IP SYN cookies
+#net/ipv4/tcp_syncookies=1
+
+# Uncomment the next line to enable packet forwarding for IPv4
+#net/ipv4/ip_forward=1
+
+# Uncomment the next line to enable packet forwarding for IPv6
+#net/ipv6/ip_forward=1
diff --git a/packages/busybox/busybox_1.01.bb b/packages/busybox/busybox_1.01.bb
index 3173294398..693ead532a 100644
--- a/packages/busybox/busybox_1.01.bb
+++ b/packages/busybox/busybox_1.01.bb
@@ -10,7 +10,7 @@ HOMEPAGE = "http://www.busybox.net"
LICENSE = "GPL"
SECTION = "base"
PRIORITY = "required"
-PR = "r7"
+PR = "r8"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://udhcppidfile.patch;patch=1 \
@@ -39,6 +39,7 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://syslog.conf \
file://mount.busybox \
file://umount.busybox"
+SRC_URI_slugos += " file://sysctl.conf "
S = "${WORKDIR}/busybox-${PV}"
@@ -130,6 +131,11 @@ do_install () {
install -m 0644 ${S}/busybox.links ${D}${sysconfdir}
}
+do_install_append_slugos()
+{
+ install -m 0644 ${WORKDIR}/sysctl.conf ${D}${sysconfdir}
+}
+
pkg_postinst_${PN} () {
# If we are not making an image we create links for the utilities that doesn't exist
# so the update-alternatives script will get the utilities it needs