summaryrefslogtreecommitdiff
path: root/packages/busybox/slingbox_1.1.3.bb
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2006-05-25 22:11:33 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-25 22:11:33 +0000
commit80816b62566e1b3175e00382c3076057bb6d46a1 (patch)
treeab4959facfbc48ffec4816c0b7502c627ca264aa /packages/busybox/slingbox_1.1.3.bb
parent34cf420fab70b5b1a11a42c864a39bbcf8fb42d8 (diff)
Unslung slingbox: upgrade slingbox to 1.1.3 busybox base
Diffstat (limited to 'packages/busybox/slingbox_1.1.3.bb')
-rw-r--r--packages/busybox/slingbox_1.1.3.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/packages/busybox/slingbox_1.1.3.bb b/packages/busybox/slingbox_1.1.3.bb
new file mode 100644
index 0000000000..5fc31dec41
--- /dev/null
+++ b/packages/busybox/slingbox_1.1.3.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "SlingBox is a minimal version of BusyBox with just enough functionality \
+to enable ipkg to run on an Unslung NSLU2 device."
+HOMEPAGE = "http://www.busybox.net"
+LICENSE = "GPL"
+SECTION = "base"
+PRIORITY = "required"
+PR = "r1"
+
+SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
+ file://defconfig \
+ file://Makefile_args.patch;patch=1 \
+ file://lazy_umount.patch;patch=1 \
+ file://slingbox_name.patch;patch=1 \
+ file://slingbox.patch;patch=1"
+
+S = "${WORKDIR}/busybox-${PV}"
+
+python () {
+ # Don't build slingbox unless we're targeting an nslu2
+ if bb.data.getVar("MACHINE", d, 1) != "nslu2":
+ raise bb.parse.SkipPackage("slingbox only builds for the Linksys NSLU2")
+}
+
+export EXTRA_CFLAGS = "${CFLAGS}"
+EXTRA_OEMAKE_append = " CROSS=${HOST_PREFIX}"
+
+PACKAGES = "${PN}"
+FILES_${PN} = "/"
+FILES_${PN}-doc = ""
+FILES_${PN}-dev = ""
+FILES_${PN}-locale = ""
+
+inherit cml1
+
+do_configure () {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ cml1_do_configure
+}
+
+do_compile () {
+ unset CFLAGS
+ base_do_compile
+}
+
+do_install () {
+ oe_runmake 'PREFIX=${D}' install
+}