summaryrefslogtreecommitdiff
path: root/packages/busybox/busybox_1.00.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-05-25 17:14:37 +0000
committerJohn Bowler <jbowler@nslu2-linux.org>2005-05-25 17:14:37 +0000
commitab67512dd0019cd2d0f1beb718de0fe255037509 (patch)
tree35cffb92c34aef7e3436c94955bfa21b7e702e78 /packages/busybox/busybox_1.00.bb
parentb59f7b5c9da751e5ef22f523565239cd75d76f74 (diff)
Merge with OE (there may still be a bug in the busybox postinst script)
2005/05/25 16:24:12+01:00 reciva.com!pb patch usb.rc to work with busybox (no "grep -o") 2005/05/25 13:09:04+01:00 reciva.com!pb Merge bk://oe-devel@openembedded-devel.bkbits.net/openembedded into mill.internal.reciva.com:/nexus/home/pb/oe/oe 2005/05/25 13:05:58+01:00 reciva.com!pb apply patch to udhcpc to send the current hostname if no -H option is given 2005/05/25 12:54:31+02:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/05/25 12:54:19+02:00 uni-frankfurt.de!mickeyl fix yacc in bison-native 2005/05/25 11:48:52+01:00 reciva.com!pb turn on support for "readlink -f", needed by usbutils 2005/05/25 11:40:50+01:00 reciva.com!pb Merge bk://oe-devel@openembedded-devel.bkbits.net/openembedded into mill.internal.reciva.com:/nexus/home/pb/oe/oe 2005/05/25 11:37:22+01:00 reciva.com!pb don't require /etc/httpd.conf to start busybox httpd, it works fine without that file 2005/05/25 12:29:58+02:00 handhelds.org!CoreDump Add altboot: A text based 'boot manager' (/sbin/init hack) to allow booting from SD and CF, boot a recovery shell (init=/bin/sh) or boot into a GUI-less runlevel 2005/05/25 11:24:50+01:00 reciva.com!pb package busybox udhcpd bits separately; remove stray copy of main postinst in -httpd package. 2005/05/25 11:52:12+02:00 local!hrw Merge bk://oe-devel.bkbits.net/openembedded into marcinj.local:/home/hrw/zaurus/oe/openembedded 2005/05/25 11:51:20+02:00 local!hrw regenerated dejavu fonts 2005/05/25 10:50:32+01:00 reciva.com!pb set default update-rc.d parameters to "defaults" BKrev: 4294b27d6MVA-cFYArKaJud80nBnzA
Diffstat (limited to 'packages/busybox/busybox_1.00.bb')
-rw-r--r--packages/busybox/busybox_1.00.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/packages/busybox/busybox_1.00.bb b/packages/busybox/busybox_1.00.bb
index 8554b95bd9..6d26dfa014 100644
--- a/packages/busybox/busybox_1.00.bb
+++ b/packages/busybox/busybox_1.00.bb
@@ -10,7 +10,7 @@ HOMEPAGE = "http://www.busybox.net"
LICENSE = "GPL"
SECTION = "base"
PRIORITY = "required"
-PR = "r21"
+PR = "r23"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://add-getkey-applet.patch;patch=1 \
@@ -26,6 +26,7 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://fbset.patch;patch=1 \
file://mount-all-type.patch;patch=1 \
file://celf-ash-builtins.patch;patch=1 \
+ file://dhcp-hostname.patch;patch=1 \
file://defconfig \
file://busybox-cron \
file://busybox-httpd \
@@ -41,14 +42,16 @@ S = "${WORKDIR}/busybox-${PV}"
export EXTRA_CFLAGS = "${CFLAGS}"
EXTRA_OEMAKE_append = " CROSS=${HOST_PREFIX}"
-PACKAGES =+ "${PN}-httpd"
+PACKAGES =+ "${PN}-httpd ${PN}-udhcpd"
FILES_${PN}-httpd = "${sysconfdir}/init.d/busybox-httpd /srv/www"
+FILES_${PN}-udhcpd = "${sysconfdir}/init.d/busybox-udhcpd"
FILES_${PN} += " ${datadir}/udhcpc"
-INITSCRIPT_PACKAGES = "${PN} ${PN}-httpd"
+INITSCRIPT_PACKAGES = "${PN} ${PN}-httpd ${PN}-udhcpd"
INITSCRIPT_NAME_${PN}-httpd = "busybox-httpd"
+INITSCRIPT_NAME_${PN}-udhcpd = "busybox-udhcpd"
INITSCRIPT_NAME_${PN} = "syslog"
inherit cml1 update-rc.d
@@ -93,12 +96,12 @@ do_install () {
install -m 0755 ${WORKDIR}/umount.busybox ${D}${base_bindir}/
}
-pkg_postinst () {
+pkg_postinst_${PN} () {
update-alternatives --install /bin/mount mount /bin/mount.busybox 50
update-alternatives --install /bin/umount umount /bin/umount.busybox 50
}
-pkg_prerm () {
+pkg_prerm_${PN} () {
update-alternatives --remove mount /bin/mount.busybox
update-alternatives --remove umount /bin/umount.busybox
}