summaryrefslogtreecommitdiff
path: root/packages/boost
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-09-22 22:00:12 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-09-22 22:00:12 +0000
commitc48723e9b9adfc6a315e0da5f0dca7fa41c2ed76 (patch)
treea63213cd61e0b48376b0887697c5188578f64ad8 /packages/boost
parent6175b1e464abe51c43d56376dcc162ac39365bad (diff)
parent653773873c33648dc59a626f4cdec44f68851832 (diff)
merge of '52b9d3a5d26a11cc7dbe318e7eb6f1c3f6022b82'
and '5f87d1f1d728ca3992204c4cc56b070c3c58ac25'
Diffstat (limited to 'packages/boost')
-rw-r--r--packages/boost/boost_1.34.1.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/packages/boost/boost_1.34.1.bb b/packages/boost/boost_1.34.1.bb
index 68afcafea5..712bb6c566 100644
--- a/packages/boost/boost_1.34.1.bb
+++ b/packages/boost/boost_1.34.1.bb
@@ -15,7 +15,7 @@ SRC_URI = "\
file://${PV}-gcc43.patch;patch=1 \
"
-PR = "r0"
+PR = "r1"
BJAM_TOOLS = "--toolset=gcc \
'-sGCC=${CC} '${BJAM_CONF} \
@@ -39,3 +39,14 @@ do_configure() {
echo "import toolset : using ;" > tools/build/v2/user-config.jam
echo "using gcc : : ${CC} : <cflags>${CFLAGS} <cxxflags>${CXXFLAGS} <linkflags>${LDFLAGS} ;" >> tools/build/v2/user-config.jam
}
+
+do_install_append() {
+ # Since boost does not provide library files in the form
+ # lib<name>.so.<abi> and a symlink pointing to this file
+ # we need to do this manually.
+ for F in `find ${D}${libdir} -name "*.so" -maxdepth 1`; do
+ echo renaming $F to $F.${PV}
+ mv $F $F.${PV}
+ ln -sf `basename $F`.${PV} $F
+ done
+}