summaryrefslogtreecommitdiff
path: root/packages/boost/boost-jam-native_3.1.9.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-05 06:26:56 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-05 06:26:56 +0000
commit4def1ea71211f8abeed555475706fa331ac1b635 (patch)
tree6619fdfc5c8a8a48a07581fb192d4369029dee87 /packages/boost/boost-jam-native_3.1.9.bb
parentb84e7ee4183590765bb0da041ca21bd2a15587e6 (diff)
libboost, builds but untested
Diffstat (limited to 'packages/boost/boost-jam-native_3.1.9.bb')
-rw-r--r--packages/boost/boost-jam-native_3.1.9.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/boost/boost-jam-native_3.1.9.bb b/packages/boost/boost-jam-native_3.1.9.bb
new file mode 100644
index 0000000000..e13d160a37
--- /dev/null
+++ b/packages/boost/boost-jam-native_3.1.9.bb
@@ -0,0 +1,35 @@
+# The Boost web site provides free peer-reviewed portable
+# C++ source libraries. The emphasis is on libraries which
+# work well with the C++ Standard Library. The libraries are
+# intended to be widely useful, and are in regular use by
+# thousands of programmers across a broad spectrum of applications.
+DESCRIPTION = "Make system for boost (native)"
+HOMEPAGE = "http://www.boost.org/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "Boost Software License"
+
+SRC_URI = "http://download.sourceforge.net/boost/boost-jam-${PV}.tgz"
+
+inherit native
+
+S = "${WORKDIR}/boost-jam-${PV}"
+
+do_compile() {
+ set -ex
+ rm -rf bin.*
+ ./build.sh gcc
+}
+
+# This is too terrible - the build script doesn't give any good
+# way I can see to find out where the binaries are placed, so
+# rely on only one bin.foo directory being created.
+do_stage() {
+ set -ex
+ install -c -m 755 bin.*/jam ${bindir}
+ install -c -m 755 bin.*/mkjambase ${bindir}
+ install -c -m 755 bin.*/yyacc ${bindir}
+ rm -f ${bindir}/bjam
+ ln ${bindir}/jam ${bindir}/bjam
+}