summaryrefslogtreecommitdiff
path: root/packages/boost/boost-jam-native_3.1.10.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-07-16 21:49:13 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-16 21:49:13 +0000
commitb596f9f477d78eb31712117f1f8bbf1030199eac (patch)
treedbabbb317a6465a6427a061b563398f2165c5f04 /packages/boost/boost-jam-native_3.1.10.bb
parentdeff9c70d95f3153404ebf5bd9d5c3d22e3bcdbd (diff)
boost-jam-native:
- upgrade to 3.1.10 - minor description reformatting - use ${STAGING_BINDIR} in do_stage()
Diffstat (limited to 'packages/boost/boost-jam-native_3.1.10.bb')
-rw-r--r--packages/boost/boost-jam-native_3.1.10.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/boost/boost-jam-native_3.1.10.bb b/packages/boost/boost-jam-native_3.1.10.bb
new file mode 100644
index 0000000000..3a844b191e
--- /dev/null
+++ b/packages/boost/boost-jam-native_3.1.10.bb
@@ -0,0 +1,35 @@
+# The Boost web site provides free peer-reviewed portable
+# C++ source libraries. The emphasis is on libraries which
+# work well with the C++ Standard Library. The libraries are
+# intended to be widely useful, and are in regular use by
+# thousands of programmers across a broad spectrum of applications.
+DESCRIPTION = "Make system for boost (native)"
+HOMEPAGE = "http://www.boost.org/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "Boost Software License"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/boost/boost-jam-${PV}.tgz"
+S = "${WORKDIR}/boost-jam-${PV}"
+
+inherit native
+
+do_compile() {
+ set -ex
+ rm -rf bin.*
+ ./build.sh gcc
+}
+
+# This is too terrible - the build script doesn't give any good
+# way I can see to find out where the binaries are placed, so
+# rely on only one bin.foo directory being created.
+do_stage() {
+ set -ex
+ install -c -m 755 bin.*/jam ${STAGING_BINDIR}/
+ install -c -m 755 bin.*/mkjambase ${STAGING_BINDIR}/
+ install -c -m 755 bin.*/yyacc ${STAGING_BINDIR}/
+ rm -f ${STAGING_BINDIR}/bjam
+ ln -sf ./jam ${STAGING_BINDIR}/bjam
+}