summaryrefslogtreecommitdiff
path: root/packages/bluez
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-07-05 16:21:53 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-07-05 16:21:53 +0000
commit8d3f7b27e80ba08d2dc0e8167f01d27527697e06 (patch)
treeb1fa703042aa93dc9aaa90df0695211de7d9e807 /packages/bluez
parentb0dc3a8d1dc7e79b7960ee7503d80a7d43b8793f (diff)
parent2ed2875b6c56be3a2f2b9db557e22024d3e92dd6 (diff)
merge of '6ecc6574ba0db38196a290448aaaf3706bcacee3'
and '7314baf01ff720449ddb034e256e260501df588f'
Diffstat (limited to 'packages/bluez')
-rw-r--r--packages/bluez/bluez-dtl1-workaround_1.0.bb17
-rw-r--r--packages/bluez/bluez-utils.inc2
-rw-r--r--packages/bluez/bluez-utils/02dtl1_cs.sh57
-rw-r--r--packages/bluez/bluez-utils_3.11.bb6
-rw-r--r--packages/bluez/bluez-utils_3.12.bb6
-rw-r--r--packages/bluez/bluez-utils_3.4.bb2
-rw-r--r--packages/bluez/bluez-utils_3.7.bb2
-rw-r--r--packages/bluez/bluez-utils_3.8.bb4
8 files changed, 20 insertions, 76 deletions
diff --git a/packages/bluez/bluez-dtl1-workaround_1.0.bb b/packages/bluez/bluez-dtl1-workaround_1.0.bb
new file mode 100644
index 0000000000..413d220508
--- /dev/null
+++ b/packages/bluez/bluez-dtl1-workaround_1.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "A nasty hack for for dtl1-cs driver to workaround suspend/resume."
+SECTION = "console"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "file://02dtl1_cs.sh"
+
+do_install() {
+ install -d ${D}${sysconfdir}/apm/event.d/
+ install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
+}
+
+#Package 02dtl1_cs.sh, which is a nasty hack to get dtl1c_cs cards working with suspend/resume
+FILES_${PN} += "${sysconfdir}/apm/"
+
+PACKAGE_ARCH = "all"
diff --git a/packages/bluez/bluez-utils.inc b/packages/bluez/bluez-utils.inc
index b6f9660fa7..8eb4fbfbf0 100644
--- a/packages/bluez/bluez-utils.inc
+++ b/packages/bluez/bluez-utils.inc
@@ -10,7 +10,6 @@ LICENSE = "GPL"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
file://hciattach-ti-bts.patch;patch=1 \
file://handle-eintr.patch;patch=1;status=applied"
@@ -41,7 +40,6 @@ do_install_append() {
rmdir ${D}${bindir} ${D}${sbindir}
chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
- install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
install -m 0755 ${S}/daemon/.libs/passkey-agent ${D}${base_bindir}/
}
diff --git a/packages/bluez/bluez-utils/02dtl1_cs.sh b/packages/bluez/bluez-utils/02dtl1_cs.sh
deleted file mode 100644
index fd81508010..0000000000
--- a/packages/bluez/bluez-utils/02dtl1_cs.sh
+++ /dev/null
@@ -1,57 +0,0 @@
-#!/bin/sh
-
-case "$1" in
- suspend)
- if [ "`/bin/hciconfig`" != "" ]; then
- #If hciconfig outputs anything then there's probably a Bluetooth
- # CF card in the slot so shut it down.
- hcitool dc `hcitool con | grep ACL | sed 's/^.*\([0-9A-F]\{2\}\(:[0-9A-F]\{2\}\)\{5\}\).*$/\1/'`
- hciconfig hci0 down
- killall hciattach > /dev/null 2>&1
- fi
- ;;
-
- resume)
- #check for kernel version
- if [ "`uname -r | grep 2.4.`" != "" ]; then
- k="o"
- elif [ "`uname -r | grep 2.6.`" != "" ]; then
- k="ko"
- else
- exit 0
- fi
-
- if test -e /sbin/cardctl; then
- CARDCTL=/sbin/cardctl
- elif test -e /sbin/pccardctl; then
- CARDCTL=/sbin/pccardctl
- else
- exit 0
- fi
-
- if [ "`lsmod | grep hci_uart`" != "" ]; then
- #If the hci_usb module is still loaded then there's a serial based
- # Bluetooth CF card in the slot, which only needs a resume to get it going
- # again.
- rfcomm bind all
- $CARDCTL resume
- hciconfig hci0 up
- else
- # only works for nokia dtl1 cards
- for f in /lib/modules/`uname -r`/kernel/drivers/bluetooth/dtl1_cs.$k
- do
- #Enumerate all the self-contained Bluetooth CF card drivers
- f=`echo $f | sed 's/\.'$k'$//'`
- f=`basename $f`
- if [ "`lsmod | grep $f`" != "" ]; then
- #If one of these drivers is still loaded, then there is probably
- #a non-serial based Bluetooth CF card in the slot that needs
- #ejecting and reinserting to get it going again
- rfcomm bind all
- $CARDCTL eject
- $CARDCTL insert
- hciconfig hci0 up
- fi
- done
- fi
-esac
diff --git a/packages/bluez/bluez-utils_3.11.bb b/packages/bluez/bluez-utils_3.11.bb
index 2419f431f6..6cadfc1a53 100644
--- a/packages/bluez/bluez-utils_3.11.bb
+++ b/packages/bluez/bluez-utils_3.11.bb
@@ -6,9 +6,8 @@ DEPENDS += "glib-2.0"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
"
-PR = "r0"
+PR = "r1"
EXTRA_OECONF = " \
--enable-bccmd \
@@ -84,9 +83,6 @@ FILES_${PN} = " \
${base_sbindir}/hciattach \
"
-#Package 02dtl1_cs.sh, which is a nasty hack to get dtl1c_cs cards working with suspend/resume
-FILES_${PN} += "${sysconfdir}/apm/"
-
FILES_${PN}-dbg += " \
${libdir}/bluetooth/.debug \
"
diff --git a/packages/bluez/bluez-utils_3.12.bb b/packages/bluez/bluez-utils_3.12.bb
index e543eed649..4710aa6779 100644
--- a/packages/bluez/bluez-utils_3.12.bb
+++ b/packages/bluez/bluez-utils_3.12.bb
@@ -4,9 +4,8 @@ DEPENDS += "glib-2.0"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
"
-PR = "r2"
+PR = "r3"
EXTRA_OECONF = " \
--enable-bccmd \
@@ -82,9 +81,6 @@ FILES_${PN} = " \
${base_sbindir}/hciattach \
"
-#Package 02dtl1_cs.sh, which is a nasty hack to get dtl1c_cs cards working with suspend/resume
-FILES_${PN} += "${sysconfdir}/apm/"
-
FILES_${PN}-dbg += " \
${libdir}/bluetooth/.debug \
"
diff --git a/packages/bluez/bluez-utils_3.4.bb b/packages/bluez/bluez-utils_3.4.bb
index 49e6ded250..f2bbd15507 100644
--- a/packages/bluez/bluez-utils_3.4.bb
+++ b/packages/bluez/bluez-utils_3.4.bb
@@ -11,7 +11,6 @@ PR = "r1"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
file://hciattach-ti-bts.patch;patch=1"
# Almost all serial CF cards w/ manfid 0x0000,0x0000 seem to use the bcs protocol
@@ -41,7 +40,6 @@ do_install_append() {
rmdir ${D}${bindir} ${D}${sbindir}
chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
- install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
}
CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
diff --git a/packages/bluez/bluez-utils_3.7.bb b/packages/bluez/bluez-utils_3.7.bb
index 3dbaa030c1..7a76cb3200 100644
--- a/packages/bluez/bluez-utils_3.7.bb
+++ b/packages/bluez/bluez-utils_3.7.bb
@@ -11,7 +11,6 @@ PR = "r0"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
file://hciattach-ti-bts.patch;patch=1"
# Almost all serial CF cards w/ manfid 0x0000,0x0000 seem to use the bcs protocol
@@ -41,7 +40,6 @@ do_install_append() {
rmdir ${D}${bindir} ${D}${sbindir}
chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
- install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
}
CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
diff --git a/packages/bluez/bluez-utils_3.8.bb b/packages/bluez/bluez-utils_3.8.bb
index d549d12d30..f2bbd15507 100644
--- a/packages/bluez/bluez-utils_3.8.bb
+++ b/packages/bluez/bluez-utils_3.8.bb
@@ -7,11 +7,10 @@ RPROVIDES_${PN} = "bluez-pan bluez-sdp bluez-utils-dbus"
RREPLACES = "bluez-utils-dbus"
RCONFLICTS_${PN} = "bluez-utils-nodbus"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
file://hciattach-ti-bts.patch;patch=1"
# Almost all serial CF cards w/ manfid 0x0000,0x0000 seem to use the bcs protocol
@@ -41,7 +40,6 @@ do_install_append() {
rmdir ${D}${bindir} ${D}${sbindir}
chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
- install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
}
CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \