summaryrefslogtreecommitdiff
path: root/packages/bash/bash_3.2.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-11-27 20:00:21 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-11-27 20:00:21 +0000
commit28fa247ca598fad3ce28eeb342b529ee990221ff (patch)
treef290cd1295447755e695cfa19fc75e06555f8a7c /packages/bash/bash_3.2.bb
parent28ac67add5c6134ee7227a2352361e2de5b06ed7 (diff)
bash: added 3.2 with upstream patches: 001 -> 005
Diffstat (limited to 'packages/bash/bash_3.2.bb')
-rw-r--r--packages/bash/bash_3.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/bash/bash_3.2.bb b/packages/bash/bash_3.2.bb
new file mode 100644
index 0000000000..e3d6b0560c
--- /dev/null
+++ b/packages/bash/bash_3.2.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "An sh-compatible command language interpreter."
+HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
+DEPENDS = "ncurses"
+SECTION = "base/shell"
+LICENSE = "GPL"
+
+SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
+ file://001-005.patch;patch=1"
+
+inherit autotools gettext
+
+PARALLEL_MAKE = ""
+
+bindir = "/bin"
+sbindir = "/sbin"
+
+EXTRA_OECONF = "--with-ncurses"
+export CC_FOR_BUILD = "${BUILD_CC}"
+
+do_configure () {
+ gnu-configize
+ oe_runconf
+}
+
+pkg_postinst () {
+ grep -q "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
+ grep -q "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
+}