summaryrefslogtreecommitdiff
path: root/packages/bacula/bacula-client_1.38.11.bb
diff options
context:
space:
mode:
authorBastian Ballmann <balle@chaostal.de>2006-09-26 09:27:16 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-09-26 09:27:16 +0000
commit8ff230217fc5c076bce98dd25cab91a71af77952 (patch)
tree5a8743cbf93532fe386bc74dccaa4a970f5a2311 /packages/bacula/bacula-client_1.38.11.bb
parent79d5a39acc94417b40bedc12ea38596437754412 (diff)
bacula-client: added 1.38.11 - close #1420
Diffstat (limited to 'packages/bacula/bacula-client_1.38.11.bb')
-rw-r--r--packages/bacula/bacula-client_1.38.11.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/packages/bacula/bacula-client_1.38.11.bb b/packages/bacula/bacula-client_1.38.11.bb
new file mode 100644
index 0000000000..474f6110c3
--- /dev/null
+++ b/packages/bacula/bacula-client_1.38.11.bb
@@ -0,0 +1,55 @@
+DESCRIPTION = "Bacula filedaemon is the client to backup your device using Bacula a network based backup program"
+SECTION = "console/network"
+PRIORITY = "optional"
+MAINTAINER = "Bastian Ballmann <balle@chaostal.de>"
+HOMEPAGE = "http://www.bacula.org"
+LICENSE = "GPL"
+PR="r0"
+DEPENDS = "gmp openssl zlib readline"
+
+SRC_URI = "http://heanet.dl.sourceforge.net/sourceforge/bacula/bacula-1.38.11.tar.gz \
+ file://findlib-attribs.patch;patch=1;pnum=1 \
+ file://bacula-fd.init"
+
+S = "${WORKDIR}/bacula-1.38.11"
+
+# Makefile is broken using ccache
+# No idea how to fix it so I turned ccache off
+CCACHE = ""
+
+inherit autotools update-rc.d
+
+LDFLAGS += "-L${STAGING_LIBDIR}"
+CFLAGS += "-L${STAGING_LIBDIR} -I${STAGING_INCDIR}"
+
+INITSCRIPT_NAME = "bacula-fd"
+
+do_configure() {
+ oe_runconf --enable-client-only \
+ --prefix=/usr \
+ --with-working-dir=/var/lib/bacula \
+ --with-fd-user=root \
+ --with-fd-group=bacula
+}
+
+do_compile() {
+ oe_runmake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+do_install() {
+ mkdir -p ${D}/${sbindir}
+ install -m 0754 ${S}/src/filed/bacula-fd ${D}/${sbindir}/
+
+ mkdir -p ${D}/${sysconfdir}/bacula
+ install ${S}/src/filed/bacula-fd.conf ${D}/${sysconfdir}/bacula/
+}
+
+# Add group
+pkg_postinst() {
+ grep -q bacula: /etc/group || addgroup bacula
+}
+
+do_install_append() {
+ mkdir -p ${D}/${sysconfdir}/init.d
+ install ${WORKDIR}/bacula-fd.init ${D}/${sysconfdir}/init.d/bacula-fd
+}