summaryrefslogtreecommitdiff
path: root/packages/avahi
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2007-08-23 14:37:17 +0000
committerPhilip Balister <philip@balister.org>2007-08-23 14:37:17 +0000
commitb750ffba347c1f8bb7dbbe42abf31f17bf4db56c (patch)
treeb9a1078d4e94279f20e3cc85cd347e1536371515 /packages/avahi
parent613aee0a21460812751113c870f82119cd31a3e0 (diff)
parentb486be9688c105f666ba4f85907cf02c04d6fba6 (diff)
merge of '0632006dcadf27825774caa5189b1ab23bd8b08e'
and '215bca295ed86f179e1bb5082f01a1186b910b0d'
Diffstat (limited to 'packages/avahi')
-rw-r--r--packages/avahi/avahi-0.6.15/.mtn2git_empty0
-rw-r--r--packages/avahi/avahi-0.6.15/patch-avahi-daemon_dbus-protocol.c.patch28
-rw-r--r--packages/avahi/avahi-python_0.6.21.bb14
-rw-r--r--packages/avahi/avahi.inc25
-rw-r--r--packages/avahi/avahi_0.6.15.bb3
-rw-r--r--packages/avahi/avahi_0.6.16.bb1
-rw-r--r--packages/avahi/avahi_0.6.17.bb1
-rw-r--r--packages/avahi/avahi_0.6.18.bb1
-rw-r--r--packages/avahi/avahi_0.6.19.bb3
-rw-r--r--packages/avahi/avahi_0.6.20.bb3
-rw-r--r--packages/avahi/avahi_0.6.21.bb3
-rw-r--r--packages/avahi/files/configure-check-pymod.patch27
12 files changed, 63 insertions, 46 deletions
diff --git a/packages/avahi/avahi-0.6.15/.mtn2git_empty b/packages/avahi/avahi-0.6.15/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/avahi/avahi-0.6.15/.mtn2git_empty
+++ /dev/null
diff --git a/packages/avahi/avahi-0.6.15/patch-avahi-daemon_dbus-protocol.c.patch b/packages/avahi/avahi-0.6.15/patch-avahi-daemon_dbus-protocol.c.patch
deleted file mode 100644
index 0971a9eea8..0000000000
--- a/packages/avahi/avahi-0.6.15/patch-avahi-daemon_dbus-protocol.c.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-marcus 2006-11-11 02:56:18 UTC
-
- FreeBSD ports repository
-
- Modified files:
- net/avahi Makefile distinfo
- Added files:
- net/avahi/files patch-avahi-daemon_dbus-protocol.c
- Log:
- Update to 0.6.15, and fix the build with D-BUS 1.0.
-
- Revision Changes Path
- 1.43 +3 -3 ports/net/avahi/Makefile
- 1.12 +3 -3 ports/net/avahi/distinfo
- 1.3 +11 -0 ports/net/avahi/files/patch-avahi-daemon_dbus-protocol.c (new)
-
---- avahi-daemon/dbus-protocol.c.orig Fri Nov 10 21:50:07 2006
-+++ avahi-daemon/dbus-protocol.c Fri Nov 10 21:50:55 2006
-@@ -1067,7 +1067,7 @@ static int dbus_connect(void) {
- if (dbus_bus_request_name(
- server->bus,
- AVAHI_DBUS_NAME,
--#if (DBUS_VERSION_MAJOR == 0) && (DBUS_VERSION_MINOR >= 60)
-+#if ((DBUS_VERSION_MAJOR == 0) && (DBUS_VERSION_MINOR >= 60)) || DBUS_VERSION_MAJOR > 0
- DBUS_NAME_FLAG_DO_NOT_QUEUE,
- #else
- DBUS_NAME_FLAG_PROHIBIT_REPLACEMENT,
-
diff --git a/packages/avahi/avahi-python_0.6.21.bb b/packages/avahi/avahi-python_0.6.21.bb
new file mode 100644
index 0000000000..8eaac073ac
--- /dev/null
+++ b/packages/avahi/avahi-python_0.6.21.bb
@@ -0,0 +1,14 @@
+require avahi.inc
+PR = "r0"
+
+# FIXME: without --enable-gtk, avahi-discover (pygtk) won't be built
+FILES_avahi-discover = ""
+
+PROVIDES = "avahi"
+DEPENDS += "python-native"
+
+SRC_URI += "file://dbus-pre-1.1.1-support.patch;patch=1 \
+ file://configure-check-pymod.patch;patch=1"
+S = "${WORKDIR}/avahi-${PV}"
+
+AVAHI_PYTHON = "--enable-python"
diff --git a/packages/avahi/avahi.inc b/packages/avahi/avahi.inc
index 2cb986012f..991d282a3e 100644
--- a/packages/avahi/avahi.inc
+++ b/packages/avahi/avahi.inc
@@ -4,24 +4,31 @@ HOMEPAGE = "http://avahi.org"
SECTION = "network"
PRIORITY = "optional"
LICENSE = "GPL"
-PR = "r4"
+PR = "r5"
DEPENDS = "expat libdaemon dbus glib-2.0"
# uclibc has no nss
-RRECOMMENDS_append_linux = "libnss-mdns"
RRECOMMENDS_avahi-daemon_append_linux = "libnss-mdns"
-RDEPENDS_avahi-daemon = "sysvinit-pidof"
+RDEPENDS_avahi-daemon = "sysvinit-pidof update-rc.d"
+RDEPENDS_avahi-autoipd = "update-rc.d"
+RDEPENDS_avahi-discover = "python-avahi python-pygtk"
+RDEPENDS_python-avahi = "python-dbus"
SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz \
file://00avahi-autoipd file://99avahi-autoipd"
inherit autotools pkgconfig update-rc.d
+# handle update-rc.d RDEPENDS manually, we don't need it on
+# anything but avahi-daemon and avahi-autoipd
+RDEPENDS_append = ""
# TODO: build and enable all the extra stuff avahi offers
-EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
+EXTRA_OECONF = "--with-distro=debian --disable-gdbm ${AVAHI_GTK} --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 ${AVAHI_PYTHON}"
+AVAHI_PYTHON = "--disable-python"
+AVAHI_GTK = "--disable-gtk"
-PACKAGES =+ "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-autoipd avahi-utils"
+PACKAGES =+ "avahi-daemon avahi-discover libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib libavahi-ui avahi-discover-standalone avahi-autoipd avahi-utils python-avahi"
FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
FILES_libavahi-core = "${libdir}/libavahi-core.so.*"
@@ -35,6 +42,7 @@ FILES_avahi-daemon = "${sbindir}/avahi-daemon \
${datadir}/avahi/avahi-service.dtd \
${datadir}/avahi/service-types"
FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
+FILES_libavahi-ui = "${libdir}/libavahi-ui.so.*"
FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
${sysconfdir}/avahi/avahi-dnsconfd.action \
${sysconfdir}/init.d/avahi-dnsconfd"
@@ -43,7 +51,12 @@ FILES_avahi-utils = "${bindir}/avahi-*"
FILES_avahi-autoipd = "${sbindir}/avahi-autoipd \
${sysconfdir}/avahi/avahi-autoipd.action \
${sysconfdir}/udhcpc.d/*avahi-autoipd"
-
+FILES_python-avahi = "${libdir}/python*/site-packages/avahi/*"
+FILES_avahi-discover = "${bindir}/avahi-discover \
+ ${datadir}/applications/avahi-discover.desktop \
+ ${datadir}/avahi/interfaces/avahi-discover.glade"
+FILES_avahi-discover-standalone = "${bindir}/avahi-discover-standalone \
+ ${datadir}/avahi/interfaces/avahi-discover.glade"
CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
diff --git a/packages/avahi/avahi_0.6.15.bb b/packages/avahi/avahi_0.6.15.bb
deleted file mode 100644
index b7645bc50f..0000000000
--- a/packages/avahi/avahi_0.6.15.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require avahi.inc
-
-SRC_URI += "file://patch-avahi-daemon_dbus-protocol.c.patch;patch=1;pnum=0"
diff --git a/packages/avahi/avahi_0.6.16.bb b/packages/avahi/avahi_0.6.16.bb
deleted file mode 100644
index 9189734dfa..0000000000
--- a/packages/avahi/avahi_0.6.16.bb
+++ /dev/null
@@ -1 +0,0 @@
-require avahi.inc
diff --git a/packages/avahi/avahi_0.6.17.bb b/packages/avahi/avahi_0.6.17.bb
deleted file mode 100644
index 9189734dfa..0000000000
--- a/packages/avahi/avahi_0.6.17.bb
+++ /dev/null
@@ -1 +0,0 @@
-require avahi.inc
diff --git a/packages/avahi/avahi_0.6.18.bb b/packages/avahi/avahi_0.6.18.bb
deleted file mode 100644
index 9189734dfa..0000000000
--- a/packages/avahi/avahi_0.6.18.bb
+++ /dev/null
@@ -1 +0,0 @@
-require avahi.inc
diff --git a/packages/avahi/avahi_0.6.19.bb b/packages/avahi/avahi_0.6.19.bb
index 27dcdcffcb..69763e3932 100644
--- a/packages/avahi/avahi_0.6.19.bb
+++ b/packages/avahi/avahi_0.6.19.bb
@@ -1,3 +1,2 @@
require avahi.inc
-
-PR = "r1"
+PR = "r2"
diff --git a/packages/avahi/avahi_0.6.20.bb b/packages/avahi/avahi_0.6.20.bb
index 59de20446c..0b7fe70be5 100644
--- a/packages/avahi/avahi_0.6.20.bb
+++ b/packages/avahi/avahi_0.6.20.bb
@@ -1,3 +1,2 @@
require avahi.inc
-
-PR = "r0"
+PR = "r1"
diff --git a/packages/avahi/avahi_0.6.21.bb b/packages/avahi/avahi_0.6.21.bb
index fb6191e53a..fa3fef039e 100644
--- a/packages/avahi/avahi_0.6.21.bb
+++ b/packages/avahi/avahi_0.6.21.bb
@@ -1,5 +1,4 @@
require avahi.inc
-
-PR = "r0"
+PR = "r1"
SRC_URI += "file://dbus-pre-1.1.1-support.patch;patch=1"
diff --git a/packages/avahi/files/configure-check-pymod.patch b/packages/avahi/files/configure-check-pymod.patch
new file mode 100644
index 0000000000..e2df5d6fc0
--- /dev/null
+++ b/packages/avahi/files/configure-check-pymod.patch
@@ -0,0 +1,27 @@
+Index: avahi-0.6.21/configure.ac
+===================================================================
+--- avahi-0.6.21.orig/configure.ac 2007-08-16 21:36:12.000000000 +0200
++++ avahi-0.6.21/configure.ac 2007-08-16 21:45:14.000000000 +0200
+@@ -700,10 +700,6 @@
+ esac],
+ [HAVE_PYGTK=yes])
+
+- if test "x$HAVE_PYGTK" = "xyes" ; then
+- AM_CHECK_PYMOD(gtk,,,[AC_MSG_ERROR(Could not find Python module gtk)])
+- fi
+-
+
+ if test "x$HAVE_DBUS" = "xyes" ; then
+ AC_ARG_ENABLE(python-dbus,
+@@ -715,11 +711,6 @@
+ esac],
+ [HAVE_PYTHON_DBUS=yes])
+
+- if test "x$HAVE_PYTHON_DBUS" = "xyes"; then
+- AM_CHECK_PYMOD(dbus,,,[AC_MSG_ERROR(Could not find Python module dbus)])
+- fi
+-
+- AM_CHECK_PYMOD(socket,,,[AC_MSG_ERROR(Could not find Python module socket)])
+ if test "x$HAVE_GDBM" = "xyes"; then
+ AM_CHECK_PYMOD(gdbm,,,[AC_MSG_ERROR(Could not find Python module gdbm)])
+ fi