summaryrefslogtreecommitdiff
path: root/packages/asterisk/asterisk_1.2.24.bb
diff options
context:
space:
mode:
authorStelios Koroneos <skoroneos@digital-opsis.com>2007-08-08 18:27:32 +0000
committerStelios Koroneos <skoroneos@digital-opsis.com>2007-08-08 18:27:32 +0000
commit4f04f6228aebccae160e5694c34e5e621579dc9b (patch)
tree66f48d5c0b64c3c486421263def7d8f601e89862 /packages/asterisk/asterisk_1.2.24.bb
parent23565dca658348d15acb9fc272be7d9e8d28a6e2 (diff)
packages/asterisk/asterisk_1.2.24.bb: New package asterisk_1.2.24
Digium release note :Version 1.2.24 is the final 1.2 release that contains normal bug fixes. The 1.2 branch will only be maintained with security fix releases from now until it is completely deprecated mental note : get 1.4 working from the bugtracker
Diffstat (limited to 'packages/asterisk/asterisk_1.2.24.bb')
-rw-r--r--packages/asterisk/asterisk_1.2.24.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/packages/asterisk/asterisk_1.2.24.bb b/packages/asterisk/asterisk_1.2.24.bb
new file mode 100644
index 0000000000..01b825d19e
--- /dev/null
+++ b/packages/asterisk/asterisk_1.2.24.bb
@@ -0,0 +1,46 @@
+# Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+DESCRIPTION="The Asterisk open source software PBX"
+HOMEPAGE="www.asterisk.org"
+LICENSE="GPL"
+DEPENDS="ncurses zlib openssl curl alsa-lib libogg libvorbis speex"
+SECTION = "console/telephony"
+PR = "r0"
+
+SRC_URI="http://ftp.digium.com/pub/asterisk/releases/asterisk-${PV}.tar.gz \
+ file://uclibc-compat-getloadavg.patch;patch=1 \
+ file://uclibc-dns.patch;patch=1 \
+ file://asterisk.patch;patch=1 \
+ file://enable-speex.patch;patch=1"
+
+S = "${WORKDIR}/asterisk-${PV}"
+
+
+export CROSS_COMPILE="${CCACHE}${HOST_PREFIX}"
+export CROSS_COMPILE_BIN="${STAGING_BINDIR_CROSS}"
+export CROSS_COMPILE_TARGET="${STAGING_DIR}/${HOST_SYS}"
+
+export CROSS_ARCH="Linux"
+export CROSS_PROC="${TARGET_ARCH}"
+
+export MAKECMDGOALS="dont-optimize"
+
+# We will probably have to edit the CFLAG in the Makefile
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/asterisk
+ install -m 0644 ${S}/include/asterisk/*.h ${STAGING_INCDIR}/asterisk/
+}
+
+
+FILES_${PN}-dbg += "${libdir}/asterisk/modules/.debug"
+FILES_${PN}-dbg += "/var/lib/asterisk/agi-bin/.debug"
+