summaryrefslogtreecommitdiff
path: root/packages/asterisk/asterisk_1.2.23.bb
diff options
context:
space:
mode:
authorStelios Koroneos <skoroneos@digital-opsis.com>2007-07-26 13:54:30 +0000
committerStelios Koroneos <skoroneos@digital-opsis.com>2007-07-26 13:54:30 +0000
commitf03685ab6480294ba673f9aff7fc7d66839392f0 (patch)
treee371428d30b078e2ebc3a0577d003bdfef0d8351 /packages/asterisk/asterisk_1.2.23.bb
parent0b76fcd34931913aaa1ce37b010eb205acd8019b (diff)
packages/asterisk/asterisk-1.2.23 : Add asterisk 1.2.23 which has some
vulnerability fixes
Diffstat (limited to 'packages/asterisk/asterisk_1.2.23.bb')
-rw-r--r--packages/asterisk/asterisk_1.2.23.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/packages/asterisk/asterisk_1.2.23.bb b/packages/asterisk/asterisk_1.2.23.bb
new file mode 100644
index 0000000000..3d91637dba
--- /dev/null
+++ b/packages/asterisk/asterisk_1.2.23.bb
@@ -0,0 +1,44 @@
+DESCRIPTION="The Asterisk open source software PBX"
+HOMEPAGE="www.asterisk.org"
+LICENSE="GPL"
+DEPENDS="ncurses zlib openssl curl alsa-lib libogg libvorbis speex"
+SECTION = "console/telephony"
+PR = "r0"
+
+SRC_URI="http://ftp.digium.com/pub/asterisk/releases/asterisk-${PV}.tar.gz \
+ file://uclibc-compat-getloadavg.patch;patch=1 \
+ file://uclibc-dns.patch;patch=1 \
+ file://asterisk.patch;patch=1 \
+ file://enable-speex.patch;patch=1"
+
+S = "${WORKDIR}/asterisk-${PV}"
+
+
+export CROSS_COMPILE="${CCACHE}${HOST_PREFIX}"
+export CROSS_COMPILE_BIN="${STAGING_BINDIR_CROSS}"
+export CROSS_COMPILE_TARGET="${STAGING_DIR}/${HOST_SYS}"
+
+export CROSS_ARCH="Linux"
+export CROSS_PROC="${TARGET_ARCH}"
+
+export MAKECMDGOALS="dont-optimize"
+
+# We will probably have to edit the CFLAG in the Makefile
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/asterisk
+ install -m 0644 ${S}/include/asterisk/*.h ${STAGING_INCDIR}/asterisk/
+}
+
+
+FILES_${PN}-dbg += "${libdir}/asterisk/modules/.debug"
+FILES_${PN}-dbg += "/var/lib/asterisk/agi-bin/.debug"
+