summaryrefslogtreecommitdiff
path: root/packages/asterisk/asterisk_1.2.14.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-01-22 10:04:30 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-01-22 10:04:30 +0000
commitc3be2a552db104291accd82b2e674d31d5527fcc (patch)
tree422e82bf481b26c2a0e883d60b459cbc243d436e /packages/asterisk/asterisk_1.2.14.bb
parent3a508238c49e86e0476319bfe71a24fdfdd56b66 (diff)
parent4693c8ab28f246ce11a0b80b27ab6127aea14c52 (diff)
merge of '77df6e755fc8272db3fd5e4c3b0620b4453ca180'
and 'f0261ce1c4acd6350d91bdaaf2939442d84a222d'
Diffstat (limited to 'packages/asterisk/asterisk_1.2.14.bb')
-rw-r--r--packages/asterisk/asterisk_1.2.14.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/asterisk/asterisk_1.2.14.bb b/packages/asterisk/asterisk_1.2.14.bb
new file mode 100644
index 0000000000..42a3214f0a
--- /dev/null
+++ b/packages/asterisk/asterisk_1.2.14.bb
@@ -0,0 +1,38 @@
+DESCRIPTION="The Asterisk open source software PBX"
+HOMEPAGE="www.asterisk.org"
+LICENSE="GPL"
+DEPENDS="ncurses zlib openssl curl alsa-lib libogg libvorbis popt"
+PR = "r1"
+
+SRC_URI="http://ftp.digium.com/pub/asterisk/releases/asterisk-${PV}.tar.gz \
+ file://uclibc-compat-getloadavg.patch;patch=1 \
+ file://uclibc-dsn.patch;patch=1 \
+ file://asterisk.patch;patch=1"
+
+
+export CROSS_COMPILE="${CCACHE}${HOST_PREFIX}"
+export CROSS_COMPILE_BIN="${STAGING_BINDIR_CROSS}"
+export CROSS_COMPILE_TARGET="${STAGING_DIR}/${HOST_SYS}"
+
+export CROSS_ARCH="Linux"
+export CROSS_PROC="arm"
+export SUB_PROC="xscale"
+
+export MAKECMDGOALS="dont-optimize"
+
+# We will probably have to edit the CFLAG in the Makefile
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/asterisk
+ install -m 0644 ${S}/include/asterisk/*.h ${STAGING_INCDIR}/asterisk/
+}
+
+