summaryrefslogtreecommitdiff
path: root/packages/aspell/aspell-lang.inc
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-04-03 11:14:00 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-04-03 11:14:00 +0000
commitcf4d59a97856faf1e539ec3b48feb155d5cefb6f (patch)
treef0e8a74a7c00ab7f3353ada856ab4a01d87dc582 /packages/aspell/aspell-lang.inc
parente1952029899a1212b48eb42080808acff8869a0a (diff)
aspell-native_0.60.5.bb, aspell6-en_6.0-0.bb, aspell_0.60.5.bb : some
speeling cheecker (spelling checker) updates. Moved to latest version of aspell and dictionaries.
Diffstat (limited to 'packages/aspell/aspell-lang.inc')
-rw-r--r--packages/aspell/aspell-lang.inc15
1 files changed, 6 insertions, 9 deletions
diff --git a/packages/aspell/aspell-lang.inc b/packages/aspell/aspell-lang.inc
index 709183b428..8c58136f0e 100644
--- a/packages/aspell/aspell-lang.inc
+++ b/packages/aspell/aspell-lang.inc
@@ -1,23 +1,20 @@
-FILES_${PN} = "/usr/lib/aspell/* /usr/share/aspell/*"
+FILES_${PN} = "/usr/lib/aspell* /usr/share/aspell*"
DEPENDS = "aspell-native"
do_configure() {
cd ${S}
- export dictdir=/usr/lib/aspell/
- export datadir=/usr/share/aspell/
- DESTDIR=${D} ./configure
+ DESTDIR=${D} ./configure --vars ASPELL=${STAGING_BINDIR_NATIVE}/aspell
}
do_compile() {
- export dictdir=/usr/lib/aspell/
- export datadir=/usr/share/aspell/
- dictdir=/usr/lib/aspell oe_runmake
+ sed -i -e "s|dictdir.*lib|dictdir = ${libdir}|" Makefile
+ sed -i -e "s|datadir.*lib|datadir = ${libdir}|" Makefile
+ oe_runmake
}
do_install() {
- export dictdir=/usr/lib/aspell/
- export datadir=/usr/share/aspell/
+ unset datadir
oe_runmake install
}