summaryrefslogtreecommitdiff
path: root/packages/apt/apt_0.7.19.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2008-12-15 14:10:58 +0000
committerGraeme Gregory <dp@xora.org.uk>2008-12-15 14:12:31 +0000
commit8336b98bd5aff057be22d30ad3c96487a793fe60 (patch)
treee5f1887250cd3742590597b9e4c24f65e9a374fe /packages/apt/apt_0.7.19.bb
parent14f8f793b6a3de55e352b4b7d2099fed537e71ff (diff)
apt_0.7.19.bb, apt-native_0.7.19.bb : add a new fetchable version of apt
Diffstat (limited to 'packages/apt/apt_0.7.19.bb')
-rw-r--r--packages/apt/apt_0.7.19.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/apt/apt_0.7.19.bb b/packages/apt/apt_0.7.19.bb
new file mode 100644
index 0000000000..251ed6416d
--- /dev/null
+++ b/packages/apt/apt_0.7.19.bb
@@ -0,0 +1,27 @@
+DEPENDS = "curl db"
+RDEPENDS = "dpkg"
+
+require apt.inc
+
+SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \
+ file://no-ko-translation.patch;patch=1 \
+ file://use-host.patch;patch=1 "
+PR = "r2"
+
+SRC_URI += "file://nodoc.patch;patch=1"
+
+require apt-package.inc
+
+FILES_${PN} += "${bindir}/apt-key"
+apt-manpages += "doc/apt-key.8"
+
+do_stage() {
+ install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/apt-pkg
+ eval `cat environment.mak | grep ^GLIBC_VER | sed -e's, = ,=,'`
+ oe_libinstall -so -C bin libapt-pkg$GLIBC_VER-6 ${STAGING_LIBDIR}/
+ ln -sf libapt-pkg$GLIBC_VER-6.so ${STAGING_LIBDIR}/libapt-pkg.so
+ oe_libinstall -so -C bin libapt-inst$GLIBC_VER-6 ${STAGING_LIBDIR}/
+ ln -sf libapt-inst$GLIBC_VER-6.so ${STAGING_LIBDIR}/libapt-inst.so
+
+ install -m 0644 include/apt-pkg/*.h ${STAGING_INCDIR}/apt-pkg/
+}