summaryrefslogtreecommitdiff
path: root/packages/apt/apt.inc
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-03-29 11:56:01 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-03-29 11:56:01 +0000
commitedc40a59a0f44223deacd1291e5e80b7b9360897 (patch)
treeb926b25545128093619fded13f3ca2255e1ddd66 /packages/apt/apt.inc
parent59fda25ab6c5091f0f4fd462f54a4555d5f9faf1 (diff)
packages/apt/apt_0.6.46.2.bb
packages/apt/apt.inc packages/apt/apt-package.inc : build and package shared libs at all times.
Diffstat (limited to 'packages/apt/apt.inc')
-rw-r--r--packages/apt/apt.inc6
1 files changed, 4 insertions, 2 deletions
diff --git a/packages/apt/apt.inc b/packages/apt/apt.inc
index dbf5765205..283b80d662 100644
--- a/packages/apt/apt.inc
+++ b/packages/apt/apt.inc
@@ -2,7 +2,8 @@ DESCRIPTION = "Advanced front-end for dpkg."
LICENSE = "GPL"
SECTION = "base"
-SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz"
+SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \
+ file://environment.patch;patch=1"
S = "${WORKDIR}/apt-${PV}"
inherit autotools gettext
@@ -12,4 +13,5 @@ EXTRA_AUTORECONF = "--exclude=autopoint,autoheader"
# Apt wants to know the glibc version by running a binary file, which will fail, so we have to tell configure which version to use
# Since I don't know the impliations of setting a wrong value I only provide one for angstrom, which uses glibc 2.5 (which claims to be 2.4)
# Koen - 20070327
-EXTRA_OECONF_angstrom += " ac_cv_glibc_ver=libc6.4"
+EXTRA_OECONF_append_angstrom = " ac_cv_glibc_ver=libc6.4"
+