summaryrefslogtreecommitdiff
path: root/packages/apr/apr-util_1.2.12.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-02-06 19:35:13 +0100
committerKoen Kooi <koen@openembedded.org>2009-02-06 19:35:13 +0100
commit445938a38d965ac7cfaf23dc2bdb6bfaa6a2e294 (patch)
treeca7a173ffd4257c57f5080e8285fc9b1e2bc8f3b /packages/apr/apr-util_1.2.12.bb
parent1a4a35664c61707a7187968fd87f1f0f980c0e0e (diff)
apr-util: fix most libtool problems
Diffstat (limited to 'packages/apr/apr-util_1.2.12.bb')
-rw-r--r--packages/apr/apr-util_1.2.12.bb12
1 files changed, 9 insertions, 3 deletions
diff --git a/packages/apr/apr-util_1.2.12.bb b/packages/apr/apr-util_1.2.12.bb
index 64f6bcbcf8..6613ab99a8 100644
--- a/packages/apr/apr-util_1.2.12.bb
+++ b/packages/apr/apr-util_1.2.12.bb
@@ -3,7 +3,9 @@ SECTION = "libs"
DEPENDS = "apr expat gdbm"
LICENSE = "Apache License, Version 2.0"
-PR = "r2"
+PR = "r3"
+
+inherit autotools lib_package binconfig
# apache mirrors?
SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
@@ -16,12 +18,16 @@ EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm \
--with-expat=${STAGING_DIR_HOST}${layout_prefix}"
-inherit autotools lib_package binconfig
-
OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+EXTRA_OEMAKE = " LIBTOOL=\"${S}/${TARGET_PREFIX}libtool\" "
+
+export LIBTOOL="${S}/${TARGET_PREFIX}libtool"
do_configure_prepend() {
+ cp ${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool ${S}/
cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+ echo "AC_PROG_LIBTOOL" >> ${S}/configure.in
+ libtoolize --force
}
do_stage() {