summaryrefslogtreecommitdiff
path: root/packages/apr/apr-util_1.2.12.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2008-03-09 01:54:34 +0000
committerRichard Purdie <rpurdie@rpsys.net>2008-03-09 01:54:34 +0000
commitce4a0ea8a254fa2678fafbbe5875742686726c65 (patch)
tree332a143f83b5f7eb492f9c149c705e4a739fc1ef /packages/apr/apr-util_1.2.12.bb
parent6238462f51f71dade7022e0a87dba01edf7ff0b0 (diff)
apr-util: Add 1.2.12 version, run full autoreconf and match apr changes
Diffstat (limited to 'packages/apr/apr-util_1.2.12.bb')
-rw-r--r--packages/apr/apr-util_1.2.12.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/apr/apr-util_1.2.12.bb b/packages/apr/apr-util_1.2.12.bb
new file mode 100644
index 0000000000..64f6bcbcf8
--- /dev/null
+++ b/packages/apr/apr-util_1.2.12.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Apache Portable Runtime (APR) companion library"
+SECTION = "libs"
+DEPENDS = "apr expat gdbm"
+LICENSE = "Apache License, Version 2.0"
+
+PR = "r2"
+
+# apache mirrors?
+SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
+ file://configure_fixes.patch;patch=1"
+
+EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm \
+ --with-gdbm=${STAGING_DIR_HOST}${layout_prefix} \
+ --without-sqlite2 \
+ --without-sqlite3 \
+ --with-expat=${STAGING_DIR_HOST}${layout_prefix}"
+
+
+inherit autotools lib_package binconfig
+
+OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+
+do_configure_prepend() {
+ cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+}
+
+do_stage() {
+ autotools_stage_all
+}